summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-15 22:07:33 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-15 22:12:40 -0400
commitb2a5c53737e86e213c4ff9f5a16f246900f8a245 (patch)
tree8b7cd6f858916707d0bdb00a5068953d12bdd924 /dev-python/pyocr
parentmedia-libs/vulkan-layers: Bump dep (diff)
downloadgentoo-b2a5c53737e86e213c4ff9f5a16f246900f8a245.tar.gz
gentoo-b2a5c53737e86e213c4ff9f5a16f246900f8a245.tar.bz2
gentoo-b2a5c53737e86e213c4ff9f5a16f246900f8a245.zip
dev-python/pyocr: remove support for USE=cuneiform
It defaults to tesseract anyway, and cuneiform hasn't been maintained since 2011 and generally doesn't build. Unlikely anyone has any desire to use it. Upstream only continues to support cuneiform at all because they want to "exercise the code" with regard to its support for multiple runtime-switchable backends. cuneiform is being last-rited. In the unlikely event someone was using it, they will be warned to uninstall it and install tesseract instead by the mask. If they really don't want to, they can ignore the mask *and* the pyocr rebuild. In the event that people were using tesseract, they are perfectly fine anyway and don't need to rebuild (but changed-deps and changed-use will both try to rebuild). No revbump. Bug: https://bugs.gentoo.org/937994 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-python/pyocr')
-rw-r--r--dev-python/pyocr/metadata.xml4
-rw-r--r--dev-python/pyocr/pyocr-0.8.5.ebuild8
2 files changed, 1 insertions, 11 deletions
diff --git a/dev-python/pyocr/metadata.xml b/dev-python/pyocr/metadata.xml
index e1321cacc717..beb8d206fc3a 100644
--- a/dev-python/pyocr/metadata.xml
+++ b/dev-python/pyocr/metadata.xml
@@ -15,10 +15,6 @@ It has been tested only on GNU/Linux systems. It should also work on similar sys
Pyocr can be used as a wrapper for google's Tesseract-OCR or Cuneiform. It can read all image types supported by Pillow, including jpeg, png, gif, bmp, tiff, and others. It also support bounding box data.
</longdescription>
- <use>
- <flag name="cuneiform">Enable support for the <pkg>app-text/cuneiform</pkg> OCR engine</flag>
- <flag name="tesseract">Enable support for the <pkg>app-text/tesseract</pkg> OCR engine</flag>
- </use>
<upstream>
<remote-id type="pypi">pyocr</remote-id>
<remote-id type="gnome-gitlab">World/OpenPaperwork/pyocr</remote-id>
diff --git a/dev-python/pyocr/pyocr-0.8.5.ebuild b/dev-python/pyocr/pyocr-0.8.5.ebuild
index 69b87eb15528..ed8f9f8ba154 100644
--- a/dev-python/pyocr/pyocr-0.8.5.ebuild
+++ b/dev-python/pyocr/pyocr-0.8.5.ebuild
@@ -17,11 +17,10 @@ HOMEPAGE="
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cuneiform +tesseract"
-REQUIRED_USE="|| ( cuneiform tesseract )"
RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
+ app-text/tesseract
"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
@@ -29,8 +28,3 @@ BDEPEND="
# (tests apparently do not require any backend installed)
distutils_enable_tests unittest
-
-RDEPEND+="
- cuneiform? ( app-text/cuneiform )
- tesseract? ( app-text/tesseract )
-"