summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:39:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:39:14 +0200
commit46ce98e6539a799ce982fe0fe328580cedfa729e (patch)
treeff8c32a00854c0e89fa9c4b941b242d77183d4c2 /dev-python/pylru
parentdev-python/zope-testing: add 4.10 (diff)
downloadgentoo-46ce98e6539a799ce982fe0fe328580cedfa729e.tar.gz
gentoo-46ce98e6539a799ce982fe0fe328580cedfa729e.tar.bz2
gentoo-46ce98e6539a799ce982fe0fe328580cedfa729e.zip
dev-python/pylru: add 1.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pylru')
-rw-r--r--dev-python/pylru/Manifest1
-rw-r--r--dev-python/pylru/pylru-1.2.1.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pylru/Manifest b/dev-python/pylru/Manifest
index 80df80b8008e..ea29627055c3 100644
--- a/dev-python/pylru/Manifest
+++ b/dev-python/pylru/Manifest
@@ -1 +1,2 @@
DIST pylru-1.2.0.tar.gz 18533 BLAKE2B 6cebc3ecc91050bdf3c8f2721a7ee1768fb48692567eb2e8603e0d28fbfd01634087bf8fda0c0c3f8c9af377195623d2689f9eb59a3ad781ccfc5f58b362a734 SHA512 d4b247cb3740c2f94f4f41bd9affbb87db4e2ec8ff566978d130d08fee9df6109c13b64f22536903bf8be3ea60d4b105dd969d1156a279115b6bfedb817cdbf5
+DIST pylru-1.2.1.tar.gz 16923 BLAKE2B fce05a78d9b503e8ec51ba76007aa16ba013099f56fed990027d3adb16155e01bfb30164d9cb248051eeef8c8cf00d9f76521a69207581c53837374e4a4fb903 SHA512 06549ec128d13e00cf95638775d962c3feb25450eb26dd5cbd1275350768a3de895049b438191a9968926f4de37624e7a8774edd58b6007c040bf75a4450d727
diff --git a/dev-python/pylru/pylru-1.2.1.ebuild b/dev-python/pylru/pylru-1.2.1.ebuild
new file mode 100644
index 000000000000..a305db0736a8
--- /dev/null
+++ b/dev-python/pylru/pylru-1.2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A least recently used (LRU) cache for Python"
+HOMEPAGE="https://github.com/jlhutch/pylru"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+python_test() {
+ "${EPYTHON}" test.py || die "tests failed under ${EPYTHON}"
+}