summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 21:24:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 21:43:18 +0100
commitc20e0dfd0cf610922691989fb1b0888221d0d914 (patch)
tree83a91f0142f9a2ef50ecfee964a052a50c63d836 /dev-python/pyh2o
parentdev-python/pyaes: Switch to PEP 517 build (diff)
downloadgentoo-c20e0dfd0cf610922691989fb1b0888221d0d914.tar.gz
gentoo-c20e0dfd0cf610922691989fb1b0888221d0d914.tar.bz2
gentoo-c20e0dfd0cf610922691989fb1b0888221d0d914.zip
dev-python/pyh2o: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyh2o')
-rw-r--r--dev-python/pyh2o/pyh2o-1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyh2o/pyh2o-1-r1.ebuild b/dev-python/pyh2o/pyh2o-1-r1.ebuild
new file mode 100644
index 000000000000..ae9149a0c504
--- /dev/null
+++ b/dev-python/pyh2o/pyh2o-1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for sci-libs/libh2o"
+HOMEPAGE="https://github.com/mgorny/pyh2o/"
+SRC_URI="
+ https://github.com/mgorny/pyh2o/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sci-libs/libh2o-0.2.1:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest