summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-22 11:34:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-22 11:42:48 +0200
commit1665f373889d83b100502f159a17876e97d1a47e (patch)
treea2173cdc699198501345b5ee8f2c54b61e0e1cb5 /dev-python/pyh2o
parentsys-power/thermald: Suggest dptfxtract usage to generate config files (diff)
downloadgentoo-1665f373889d83b100502f159a17876e97d1a47e.tar.gz
gentoo-1665f373889d83b100502f159a17876e97d1a47e.tar.bz2
gentoo-1665f373889d83b100502f159a17876e97d1a47e.zip
dev-python/pyh2o: Enable tests, port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyh2o')
-rw-r--r--dev-python/pyh2o/pyh2o-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pyh2o/pyh2o-9999.ebuild b/dev-python/pyh2o/pyh2o-9999.ebuild
index 1da3c13679c3..e84d11c8c43b 100644
--- a/dev-python/pyh2o/pyh2o-9999.ebuild
+++ b/dev-python/pyh2o/pyh2o-9999.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 git-r3
@@ -18,3 +20,5 @@ IUSE=""
RDEPEND=">=sci-libs/libh2o-0.2.1:="
DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest