summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 08:33:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 08:48:22 +0200
commit67e4b45d75251c0d559167d5dfb2831e2493ba58 (patch)
treee36b87492f559f057229d3091e1129e7ddc45cc7 /dev-python/pygobject
parentdev-python/sentry-sdk: Bump to 1.25.0 (diff)
downloadgentoo-67e4b45d75251c0d559167d5dfb2831e2493ba58.tar.gz
gentoo-67e4b45d75251c0d559167d5dfb2831e2493ba58.tar.bz2
gentoo-67e4b45d75251c0d559167d5dfb2831e2493ba58.zip
dev-python/pygobject: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/pygobject-3.44.1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/pygobject/pygobject-3.44.1.ebuild b/dev-python/pygobject/pygobject-3.44.1.ebuild
index 328eb9736f93..231063a2d18f 100644
--- a/dev-python/pygobject/pygobject-3.44.1.ebuild
+++ b/dev-python/pygobject/pygobject-3.44.1.ebuild
@@ -5,12 +5,15 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit gnome.org meson virtualx xdg distutils-r1
DESCRIPTION="Python bindings for GObject Introspection"
-HOMEPAGE="https://pygobject.readthedocs.io/"
+HOMEPAGE="
+ https://pygobject.readthedocs.io/
+ https://gitlab.gnome.org/GNOME/pygobject/
+"
LICENSE="LGPL-2.1+"
SLOT="3"
@@ -41,6 +44,15 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ # workaround minor py3.12 test failure
+ # (I wish we could just use EPYTEST_DESELECT here, sigh)
+ # https://gitlab.gnome.org/GNOME/pygobject/-/issues/582
+ sed -i -e 's@Item 0: @.*@' tests/test_gi.py || die
+
+ distutils-r1_src_prepare
+}
+
python_configure() {
local emesonargs=(
$(meson_feature cairo pycairo)