summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 22:56:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:50 +0300
commit24fe2f5082bcb0871e8dd579fadf2b29a65a142c (patch)
tree08200de58ed4468a30f2a986acbe3f08250617c7 /dev-python/pyghmi
parentdev-python/canonicaljson: add 1.6.3 (diff)
downloadgentoo-24fe2f5082bcb0871e8dd579fadf2b29a65a142c.tar.gz
gentoo-24fe2f5082bcb0871e8dd579fadf2b29a65a142c.tar.bz2
gentoo-24fe2f5082bcb0871e8dd579fadf2b29a65a142c.zip
dev-python/pyghmi: add 1.5.53
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.53.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 3a46e67cabea..a45404ce74a6 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,2 +1,3 @@
DIST pyghmi-1.5.51.tar.gz 244303 BLAKE2B 9d675de9a3df5c314d5d0bf73cb0086297cf67d07d0f4488c65cbcb7ffa68aaccb9149666eded4c40984c1936a46294f113be07dd5b4e9ad772e3f40d9d29f19 SHA512 ab7f650f984f7677fcac4895c9d75f4184ae3268793c4c6682e2150c2e433b0b6c15ea7008cdd2389b5f2db992e3cae117c2bc2dc13b7d7cb3a19172fc12783c
DIST pyghmi-1.5.52.tar.gz 244775 BLAKE2B 5bfd9107f48b9e81ee4677a6dbe3100251cfa270ba2278e7edf39245dda176f0c33d550440feb0f3df9aed4afa8cc02927191be8ff5925ba1afd1ac5dda8d6a6 SHA512 5e3fde2fa34ae20165f0ab7ae703c9e285bc4db4aa30ade4af359efb25007d83b65a0f4ce48234e9596c2732fbb3dfad994b095af8ce1b4051e34472325b048b
+DIST pyghmi-1.5.53.tar.gz 245616 BLAKE2B f0dd3d84426c7d1b0e32ae6d666823f2c760b4b6022beb7224af242ab17540f02e47cb321d681ab0153b6cee67c5a35609d45b4af5f9b55896217da8eb089132 SHA512 0f598bcfbfb233ef6a9e7890b914b745c114c67a1c9a5daa6136f498af78c0f6e29e501d5e94a94d47651c11396d154925769d0d7509cc7058a0949545c7eb76
diff --git a/dev-python/pyghmi/pyghmi-1.5.53.ebuild b/dev-python/pyghmi/pyghmi-1.5.53.ebuild
new file mode 100644
index 000000000000..c181f2b930f7
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.53.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest