summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:22:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:43 +0100
commit0e09231c468f2e0252dcfe3ee7bd0607c15a9ced (patch)
treea7116133ae896ddaaa2d622934f66e407f1190e6 /dev-python/pygal
parentdev-python/plumbum: Migrate to PEP517 build (diff)
downloadgentoo-0e09231c468f2e0252dcfe3ee7bd0607c15a9ced.tar.gz
gentoo-0e09231c468f2e0252dcfe3ee7bd0607c15a9ced.tar.bz2
gentoo-0e09231c468f2e0252dcfe3ee7bd0607c15a9ced.zip
dev-python/pygal: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/pygal-3.0.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygal/pygal-3.0.0-r2.ebuild b/dev-python/pygal/pygal-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..59615d98fba6
--- /dev/null
+++ b/dev-python/pygal/pygal-3.0.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="https://github.com/Kozea/pygal/"
+SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+ )
+"
+
+# CHANGELOG is a symlink to docs/changelog.rst
+DOCS=( docs/changelog.rst README.md )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/Kozea/pygal/issues/430
+ sed -i -e "/setup_requires/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "improving rendering speed" "dev-python/lxml"
+ optfeature "png rendering" "dev-python/cairosvg"
+}