summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:34:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 11:34:21 +0200
commit49115658faf84e828ac7ad8aeecb680e6f58c23c (patch)
tree30a51635ca36919c7da3f94f6d5ecfcd77c4f3ea /dev-python/pyflakes
parentdev-python/pyflakes: Use PEP517 build (diff)
downloadgentoo-49115658faf84e828ac7ad8aeecb680e6f58c23c.tar.gz
gentoo-49115658faf84e828ac7ad8aeecb680e6f58c23c.tar.bz2
gentoo-49115658faf84e828ac7ad8aeecb680e6f58c23c.zip
dev-python/pyflakes: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/Manifest2
-rw-r--r--dev-python/pyflakes/files/pyflakes-2.2.0-fix-tests.patch97
-rw-r--r--dev-python/pyflakes/files/pyflakes-2.3.1-fix-py3.10-tests.patch91
-rw-r--r--dev-python/pyflakes/pyflakes-2.2.0.ebuild23
-rw-r--r--dev-python/pyflakes/pyflakes-2.3.1.ebuild21
5 files changed, 0 insertions, 234 deletions
diff --git a/dev-python/pyflakes/Manifest b/dev-python/pyflakes/Manifest
index b6111d4ce98b..04c263596156 100644
--- a/dev-python/pyflakes/Manifest
+++ b/dev-python/pyflakes/Manifest
@@ -1,3 +1 @@
-DIST pyflakes-2.2.0.tar.gz 65307 BLAKE2B e48e0cb0497f90b6482c0fd08c182d766ab50755fe348352df510841f4ad43f7c1d6486753ce774603a3624f49c9b0165ad930bb1451ef30cf2e828d732e0652 SHA512 6a411efef261874c216b71bcb095412448a8cbeefdf7fa5577d4f4edd48a4a740a4433665e87e5dda2c08fd9ee3bfb7f134f56c7523e1303243edfa92b0ccb35
-DIST pyflakes-2.3.1.tar.gz 68567 BLAKE2B 0eee1eb87bf1dcae68afcdb250644aa8a1189ca3d8d22608e25727bf01b94465cceb6c65be669b18779434c8879594dd92cfb3a108b7aff584cfda788f6e2f4f SHA512 85d3a2737d31ed4b5f4c2e3621759a5951d1320f95d74313fec09fa551648105b3ab84db94f7bffe5b77623e4adbea1d8ad12b9ce2fee7e81c41581a3ea81cc6
DIST pyflakes-2.4.0.tar.gz 69101 BLAKE2B 852e50f3545138947761f9a8413fd6463bb9a28977c008feb1c3a81afb3854501b8fd3c05840d9d75bc6ebf505b545e62c047b87780b0bc764fd4225ea6a1e21 SHA512 f4c6512eb811511c897623f52c4f88e50275a3292582d7dd34462e90e39fecce939818cb92e750eebdd66eab25b91c23540104fc4530c42621d7cfeb1d33c577
diff --git a/dev-python/pyflakes/files/pyflakes-2.2.0-fix-tests.patch b/dev-python/pyflakes/files/pyflakes-2.2.0-fix-tests.patch
deleted file mode 100644
index 00b1130bf342..000000000000
--- a/dev-python/pyflakes/files/pyflakes-2.2.0-fix-tests.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
-index b579ac8..d379b3b 100644
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -515,8 +513,10 @@ def foo(bar=baz, bax):
- """
- with self.makeTempFile(source) as sourcePath:
- if ERROR_HAS_LAST_LINE:
-- if PYPY and sys.version_info >= (3,):
-+ if PYPY:
- column = 7
-+ elif sys.version_info >= (3, 9):
-+ column = 21
- elif sys.version_info >= (3, 8):
- column = 9
- else:
-@@ -543,8 +543,10 @@ foo(bar=baz, bax)
- """
- with self.makeTempFile(source) as sourcePath:
- if ERROR_HAS_LAST_LINE:
-- if PYPY and sys.version_info >= (3,):
-+ if PYPY:
- column = 12
-+ elif sys.version_info >= (3, 9):
-+ column = 17
- elif sys.version_info >= (3, 8):
- column = 14
- else:
-@@ -578,7 +580,9 @@ foo(bar=baz, bax)
- else:
- position_end = 1
- if PYPY:
-- column = 6
-+ column = 5
-+ elif ver >= (3, 9):
-+ column = 13
- else:
- column = 7
- # Column has been "fixed" since 3.2.4 and 3.3.1
-@@ -717,13 +721,6 @@ class IntegrationTests(TestCase):
- """
- Tests of the pyflakes script that actually spawn the script.
- """
--
-- # https://bitbucket.org/pypy/pypy/issues/3069/pypy36-on-windows-incorrect-line-separator
-- if PYPY and sys.version_info >= (3,) and WIN:
-- LINESEP = '\n'
-- else:
-- LINESEP = os.linesep
--
- def setUp(self):
- self.tempdir = tempfile.mkdtemp()
- self.tempfilepath = os.path.join(self.tempdir, 'temp')
-@@ -784,7 +781,7 @@ class IntegrationTests(TestCase):
- fd.write("import contraband\n".encode('ascii'))
- d = self.runPyflakes([self.tempfilepath])
- expected = UnusedImport(self.tempfilepath, Node(1), 'contraband')
-- self.assertEqual(d, ("%s%s" % (expected, self.LINESEP), '', 1))
-+ self.assertEqual(d, ("%s%s" % (expected, os.linesep), '', 1))
-
- def test_errors_io(self):
- """
-@@ -794,7 +791,7 @@ class IntegrationTests(TestCase):
- """
- d = self.runPyflakes([self.tempfilepath])
- error_msg = '%s: No such file or directory%s' % (self.tempfilepath,
-- self.LINESEP)
-+ os.linesep)
- self.assertEqual(d, ('', error_msg, 1))
-
- def test_errors_syntax(self):
-@@ -807,7 +804,7 @@ class IntegrationTests(TestCase):
- fd.write("import".encode('ascii'))
- d = self.runPyflakes([self.tempfilepath])
- error_msg = '{0}:1:{2}: invalid syntax{1}import{1} {3}^{1}'.format(
-- self.tempfilepath, self.LINESEP, 6 if PYPY else 7, '' if PYPY else ' ')
-+ self.tempfilepath, os.linesep, 6 if PYPY else 7, '' if PYPY else ' ')
- self.assertEqual(d, ('', error_msg, 1))
-
- def test_readFromStdin(self):
-@@ -816,15 +813,13 @@ class IntegrationTests(TestCase):
- """
- d = self.runPyflakes([], stdin='import contraband')
- expected = UnusedImport('<stdin>', Node(1), 'contraband')
-- self.assertEqual(d, ("%s%s" % (expected, self.LINESEP), '', 1))
-+ self.assertEqual(d, ("%s%s" % (expected, os.linesep), '', 1))
-
-
- class TestMain(IntegrationTests):
- """
- Tests of the pyflakes main function.
- """
-- LINESEP = os.linesep
--
- def runPyflakes(self, paths, stdin=None):
- try:
- with SysStreamCapturing(stdin) as capture:
diff --git a/dev-python/pyflakes/files/pyflakes-2.3.1-fix-py3.10-tests.patch b/dev-python/pyflakes/files/pyflakes-2.3.1-fix-py3.10-tests.patch
deleted file mode 100644
index c96585d20c73..000000000000
--- a/dev-python/pyflakes/files/pyflakes-2.3.1-fix-py3.10-tests.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From f3b1b44bf3d2d5927004fa1c2fcf1ab2def816b9 Mon Sep 17 00:00:00 2001
-From: Anthony Sottile <asottile@umich.edu>
-Date: Thu, 20 May 2021 07:23:19 -0700
-Subject: [PATCH] fix syntax error offsets for python 3.10 (#635)
-
----
- .github/workflows/test.yml | 2 +-
- pyflakes/test/test_api.py | 43 +++++++++++++++++++++++++-------------
- tox.ini | 2 +-
- 3 files changed, 30 insertions(+), 17 deletions(-)
-
-diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
-index d379b3b7..2c1cf19d 100644
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -441,7 +441,7 @@ def evaluate(source):
- evaluate(source)
- except SyntaxError:
- e = sys.exc_info()[1]
-- if not PYPY:
-+ if not PYPY and sys.version_info < (3, 10):
- self.assertTrue(e.text.count('\n') > 1)
- else:
- self.fail()
-@@ -449,10 +449,17 @@ def evaluate(source):
- with self.makeTempFile(source) as sourcePath:
- if PYPY:
- message = 'end of file (EOF) while scanning triple-quoted string literal'
-+ elif sys.version_info >= (3, 10):
-+ message = 'unterminated triple-quoted string literal (detected at line 8)' # noqa: E501
- else:
- message = 'invalid syntax'
-
-- column = 8 if sys.version_info >= (3, 8) else 11
-+ if sys.version_info >= (3, 10):
-+ column = 12
-+ elif sys.version_info >= (3, 8):
-+ column = 8
-+ else:
-+ column = 11
- self.assertHasErrors(
- sourcePath,
- ["""\
-@@ -468,21 +475,25 @@ def test_eofSyntaxError(self):
- """
- with self.makeTempFile("def foo(") as sourcePath:
- if PYPY:
-- result = """\
--%s:1:7: parenthesis is never closed
--def foo(
-- ^
--""" % (sourcePath,)
-+ msg = 'parenthesis is never closed'
-+ elif sys.version_info >= (3, 10):
-+ msg = "'(' was never closed"
- else:
-- result = """\
--%s:1:9: unexpected EOF while parsing
--def foo(
-- ^
--""" % (sourcePath,)
-+ msg = 'unexpected EOF while parsing'
-
-- self.assertHasErrors(
-- sourcePath,
-- [result])
-+ if PYPY:
-+ column = 7
-+ elif sys.version_info >= (3, 10):
-+ column = 8
-+ else:
-+ column = 9
-+
-+ spaces = ' ' * (column - 1)
-+ expected = '{}:1:{}: {}\ndef foo(\n{}^\n'.format(
-+ sourcePath, column, msg, spaces
-+ )
-+
-+ self.assertHasErrors(sourcePath, [expected])
-
- def test_eofSyntaxErrorWithTab(self):
- """
-@@ -515,6 +526,8 @@ def foo(bar=baz, bax):
- if ERROR_HAS_LAST_LINE:
- if PYPY:
- column = 7
-+ elif sys.version_info >= (3, 10):
-+ column = 18
- elif sys.version_info >= (3, 9):
- column = 21
- elif sys.version_info >= (3, 8):
diff --git a/dev-python/pyflakes/pyflakes-2.2.0.ebuild b/dev-python/pyflakes/pyflakes-2.2.0.ebuild
deleted file mode 100644
index 879458907120..000000000000
--- a/dev-python/pyflakes/pyflakes-2.2.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-# Uses pkg_resources
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Passive checker for Python programs"
-HOMEPAGE="https://github.com/PyCQA/pyflakes https://pypi.org/project/pyflakes/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# Should be included in the next release
-PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
-
-distutils_enable_tests unittest
diff --git a/dev-python/pyflakes/pyflakes-2.3.1.ebuild b/dev-python/pyflakes/pyflakes-2.3.1.ebuild
deleted file mode 100644
index 1c9e50892545..000000000000
--- a/dev-python/pyflakes/pyflakes-2.3.1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Passive checker for Python programs"
-HOMEPAGE="https://github.com/PyCQA/pyflakes https://pypi.org/project/pyflakes/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10-tests.patch"
-)
-
-distutils_enable_tests unittest