summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-04 20:08:43 +0100
committerSam James <sam@gentoo.org>2023-07-04 20:09:19 +0100
commit2ad9afe722a7b6e774941e9a03d1e66aa827241a (patch)
treee7fbbb8ce11349cb357a371991c61e5d9a03ef5d /dev-python/pyflakes
parentdev-python/pyflakes: backport Python 3.11 fix (diff)
downloadgentoo-2ad9afe722a7b6e774941e9a03d1e66aa827241a.tar.gz
gentoo-2ad9afe722a7b6e774941e9a03d1e66aa827241a.tar.bz2
gentoo-2ad9afe722a7b6e774941e9a03d1e66aa827241a.zip
dev-python/pyflakes: disable py3.9, style tweak
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch10
-rw-r--r--dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild4
2 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch b/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
index b2e7f57b2bad..db804f42c775 100644
--- a/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
+++ b/dev-python/pyflakes/files/pyflakes-3.0.1-python3.11.patch
@@ -1,17 +1,11 @@
https://github.com/PyCQA/pyflakes/commit/836631f2f73d45baa4021453d89fc9fd6f52be58
https://bugs.gentoo.org/909554
+
From 836631f2f73d45baa4021453d89fc9fd6f52be58 Mon Sep 17 00:00:00 2001
From: Anthony Sottile <asottile@umich.edu>
Date: Mon, 12 Jun 2023 21:00:45 -0400
Subject: [PATCH] fix error reporter and testsuite in 3.11.4+ (#775)
----
- pyflakes/reporter.py | 3 ++-
- pyflakes/test/test_api.py | 8 ++++++--
- 2 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/pyflakes/reporter.py b/pyflakes/reporter.py
-index af834d1c..65ed4d8e 100644
--- a/pyflakes/reporter.py
+++ b/pyflakes/reporter.py
@@ -56,8 +56,9 @@ def syntaxError(self, filename, msg, lineno, offset, text):
@@ -25,8 +19,6 @@ index af834d1c..65ed4d8e 100644
if offset is not None:
# some versions of python emit an offset of -1 for certain encoding errors
-diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
-index 5c1879c1..13e8f685 100644
--- a/pyflakes/test/test_api.py
+++ b/pyflakes/test/test_api.py
@@ -621,8 +621,12 @@ def test_misencodedFileUTF16(self):
diff --git a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild b/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
index 2e8999e03a38..cbe9dae91c15 100644
--- a/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
+++ b/dev-python/pyflakes/pyflakes-3.0.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit distutils-r1 pypi
@@ -17,7 +17,9 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
PATCHES=(
"${FILESDIR}"/${P}-python3.11.patch
)
+
distutils_enable_tests unittest