summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-03 20:35:17 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-03 20:35:56 +0100
commitb1dfe2d473ae34419047e589dca3b5e9a4f2313e (patch)
treecafff22cae80861d20aa3b4a4ce2048365a2c590 /dev-python/pydocstyle
parentapp-containers/runc: stabilize 1.1.4 for amd64 #889546 (diff)
downloadgentoo-b1dfe2d473ae34419047e589dca3b5e9a4f2313e.tar.gz
gentoo-b1dfe2d473ae34419047e589dca3b5e9a4f2313e.tar.bz2
gentoo-b1dfe2d473ae34419047e589dca3b5e9a4f2313e.zip
dev-python/pydocstyle: add 6.2.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest1
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.2.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index 716834b1a5bb..c1821077a511 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,2 +1,3 @@
DIST pydocstyle-6.1.1.tar.gz 73982 BLAKE2B 6a896221fdcd257f0475472e1cf87ef892d8292a4c0faf661595adb17e2d18f4a8277cda498197309d34597c448203856c272256277a7e35fba20e2e5ba47f2b SHA512 ce4932a6601c80d05a46600f5af7df54798025a5f3dc41ab8cf1bc0d63e7f78b70cccb17dc99ddab25eda9abd639f91468fca1b1ceb4539708350212e481a156
DIST pydocstyle-6.2.0.gh.tar.gz 77296 BLAKE2B 22f6d8691763b6c3e41bca7d0ef5193a282189f442072089aebb6d96d2e039e971e9e5645e50f4bcb8433f36cdf0e33c956c4ac381f2e7e649d010d63f5db501 SHA512 382c74d22072337a624ac635d95c9cf5fbbd373c11c85b6302c56bf21f099ebc4dd8eec2f896a8c02d4548524078daebbceef7c4fb055dfb6a6eadab0e42a190
+DIST pydocstyle-6.2.2.gh.tar.gz 77412 BLAKE2B 5aa2eaa52e97d705fc6972db985ccb7927b856944250de8153ecdb3285bd0ec75305186a7d2e6904ccead9b4299637af83496456e2af9769fcf62fa0fae041cf SHA512 2097ec9d3429c83de821630384e717074abc39dfdff928327e8ccf4a1ba91592926ac55784403b559d88a8bb9a29557a2a406863c8603644de5d17972c63e4f5
diff --git a/dev-python/pydocstyle/pydocstyle-6.2.2.ebuild b/dev-python/pydocstyle/pydocstyle-6.2.2.ebuild
new file mode 100644
index 000000000000..34d9f103b381
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-6.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="
+ https://github.com/PyCQA/pydocstyle/
+ https://pypi.org/project/pydocstyle/
+"
+SRC_URI="
+ https://github.com/PyCQA/pydocstyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/snowballstemmer-2.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ )
+"
+
+distutils_enable_tests pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+PATCHES=(
+ "${FILESDIR}"/pydocstyle-6.1.1-disarm-pip-install.patch
+)
+
+src_prepare() {
+ # poetry sucks
+ sed -i -e "s:0.0.0-dev:${PV}:" pyproject.toml || die
+ distutils-r1_src_prepare
+}