summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 08:40:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 08:40:10 +0100
commit6b057cbe70bb46fbc9983a876e4d924b61a128b9 (patch)
treebe64739ed38a0ec7b20f16ca0c1c062cc01b4458 /dev-python/pydocstyle
parentdev-python/python-lsp-server: Remove old (diff)
downloadgentoo-6b057cbe70bb46fbc9983a876e4d924b61a128b9.tar.gz
gentoo-6b057cbe70bb46fbc9983a876e4d924b61a128b9.tar.bz2
gentoo-6b057cbe70bb46fbc9983a876e4d924b61a128b9.zip
dev-python/pydocstyle: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest1
-rw-r--r--dev-python/pydocstyle/files/pydocstyle-6.1.1-tomli.patch90
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.1.1-r2.ebuild43
3 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index 59b18c487eee..0cce48528328 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,3 +1,2 @@
-DIST pydocstyle-6.1.1.tar.gz 73982 BLAKE2B 6a896221fdcd257f0475472e1cf87ef892d8292a4c0faf661595adb17e2d18f4a8277cda498197309d34597c448203856c272256277a7e35fba20e2e5ba47f2b SHA512 ce4932a6601c80d05a46600f5af7df54798025a5f3dc41ab8cf1bc0d63e7f78b70cccb17dc99ddab25eda9abd639f91468fca1b1ceb4539708350212e481a156
DIST pydocstyle-6.2.3.gh.tar.gz 77612 BLAKE2B f94b9c8232a3e96dad1d84d37bf7cc53f114edfddbd0dad725ff3bb79f39576a5fceff5a2b962e284e9d0d96ac8d71e5aa0406322af4bf8fdc73910348ff9190 SHA512 b275bd2367a3a6d4636a2879f503da15b9965bffe2750db87cbd3ca09fc3353a481a9c38e1b35b3b2aeeba019e9dd393d2cb65db2820d6343fb4c9881f7e6deb
DIST pydocstyle-6.3.0.gh.tar.gz 78058 BLAKE2B 551da9af8baebcba4f1053e0d9495bff039a98c96ad229219cd37ac8ba9e3002fff8a136c5148144a5f84ed94a1414364d7c827ad010038f63961ce17a260ee3 SHA512 f8473b19ab6ef0b61787875558f9dd6f9f7f1954e1baa0010942af6d4de8dbca30c8c08be6acbf24aadd1c0a601ba9467b747026a6cd22379f0c4b84a38b57c7
diff --git a/dev-python/pydocstyle/files/pydocstyle-6.1.1-tomli.patch b/dev-python/pydocstyle/files/pydocstyle-6.1.1-tomli.patch
deleted file mode 100644
index 8be2adca5ba1..000000000000
--- a/dev-python/pydocstyle/files/pydocstyle-6.1.1-tomli.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From 4c9ed77d3629a69febdaa14d153d3db869b58e4f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 12 Oct 2022 16:37:40 +0200
-Subject: [PATCH] Use tomllib/tomli for reading .toml configs
-
-Use the built-in `tomllib` module in Python 3.11 and the modern `tomli`
-package in older Python versions to read .toml configs instead of
-the unmaintained and broken `toml` package.
-
-Fixes #599
-Fixes #600
----
- docs/release_notes.rst | 1 +
- requirements/runtime.txt | 2 +-
- requirements/tests.txt | 1 -
- setup.py | 2 +-
- src/pydocstyle/config.py | 20 ++++++++++++--------
- 5 files changed, 15 insertions(+), 11 deletions(-)
-
-diff --git a/requirements/runtime.txt b/requirements/runtime.txt
-index 80302751..b4e9ca76 100644
---- a/requirements/runtime.txt
-+++ b/requirements/runtime.txt
-@@ -1,2 +1,2 @@
- snowballstemmer==1.2.1
--toml==0.10.2
-+tomli==2.0.1; python_version < "3.11"
-diff --git a/setup.py b/setup.py
-index a9c5df1c..6c0671c7 100644
---- a/setup.py
-+++ b/setup.py
-@@ -8,7 +8,7 @@
- 'snowballstemmer',
- ]
- extra_requirements = {
-- 'toml': ['toml'],
-+ 'toml': ['tomli; python_version < "3.11"'],
- }
-
-
-diff --git a/src/pydocstyle/config.py b/src/pydocstyle/config.py
-index ed00c874..db7ed1b6 100644
---- a/src/pydocstyle/config.py
-+++ b/src/pydocstyle/config.py
-@@ -4,6 +4,7 @@
- import itertools
- import operator
- import os
-+import sys
- from collections import namedtuple
- from collections.abc import Set
- from configparser import NoOptionError, NoSectionError, RawConfigParser
-@@ -13,10 +14,13 @@
- from .utils import __version__, log
- from .violations import ErrorRegistry, conventions
-
--try:
-- import toml
--except ImportError: # pragma: no cover
-- toml = None # type: ignore
-+if sys.version_info >= (3, 11):
-+ import tomllib
-+else:
-+ try:
-+ import tomli as tomllib
-+ except ImportError: # pragma: no cover
-+ tomllib = None # type: ignore
-
-
- def check_initialized(method):
-@@ -59,15 +63,15 @@ def read(self, filenames, encoding=None):
- read_ok = []
- for filename in filenames:
- try:
-- with open(filename, encoding=encoding) as fp:
-- if not toml:
-+ with open(filename, "rb") as fp:
-+ if not tomllib:
- log.warning(
- "The %s configuration file was ignored, "
-- "because the `toml` package is not installed.",
-+ "because the `tomli` package is not installed.",
- filename,
- )
- continue
-- self._config.update(toml.load(fp))
-+ self._config.update(tomllib.load(fp))
- except OSError:
- continue
- if isinstance(filename, os.PathLike):
diff --git a/dev-python/pydocstyle/pydocstyle-6.1.1-r2.ebuild b/dev-python/pydocstyle/pydocstyle-6.1.1-r2.ebuild
deleted file mode 100644
index f3c4f96d22f6..000000000000
--- a/dev-python/pydocstyle/pydocstyle-6.1.1-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python docstring style checker"
-HOMEPAGE="
- https://github.com/PyCQA/pydocstyle/
- https://pypi.org/project/pydocstyle/
-"
-SRC_URI="
- https://github.com/PyCQA/pydocstyle/archive/${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/snowballstemmer[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
- )
-"
-
-distutils_enable_tests pytest
-# Requires network to lookup github issues
-#distutils_enable_sphinx docs dev-python/sphinx-rtd-theme dev-python/sphinxcontrib-issuetracker
-
-PATCHES=(
- "${FILESDIR}"/pydocstyle-6.1.1-disarm-pip-install.patch
- "${FILESDIR}"/${P}-tomli.patch
-)