summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-04-14 19:48:17 +0200
committerSebastian Pipping <sping@gentoo.org>2024-04-14 19:49:17 +0200
commitf60a09dfb2c75c9f33b4890cf09d4b8963d25fd7 (patch)
treeef7d96eb8c3e56f679f1d2cee9b32650317957ac /dev-python/pycxx
parentdev-java/commons-net: Stabilize 3.10.0 x86, #930002 (diff)
downloadgentoo-f60a09dfb2c75c9f33b4890cf09d4b8963d25fd7.tar.gz
gentoo-f60a09dfb2c75c9f33b4890cf09d4b8963d25fd7.tar.bz2
gentoo-f60a09dfb2c75c9f33b4890cf09d4b8963d25fd7.zip
dev-python/pycxx: Python 3.12
Closes: https://bugs.gentoo.org/929486 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/pycxx-7.1.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
new file mode 100644
index 000000000000..cadfdbb9e765
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}