summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:17 +0200
commit1ff8b8349b182619eec3acf90517b633bc0bbd41 (patch)
treeb8361619cc7e84b0ab361241f61b602e73fb4401 /dev-python/pycxx
parentdev-python/pycryptodome: Remove redundant versions (diff)
downloadgentoo-1ff8b8349b182619eec3acf90517b633bc0bbd41.tar.gz
gentoo-1ff8b8349b182619eec3acf90517b633bc0bbd41.tar.bz2
gentoo-1ff8b8349b182619eec3acf90517b633bc0bbd41.zip
dev-python/pycxx: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest1
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-installation.patch25
-rw-r--r--dev-python/pycxx/pycxx-6.2.6.ebuild41
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index bce88f507a96..f483a5224d93 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,2 +1 @@
-DIST pycxx-6.2.6.tar.gz 141547 BLAKE2B e067d2a3f7ce58200c3b97f971692f64545f224929308c6e9a668a15eb775580060e860cf8ba1f894ae61320aa3454622f15fcc6fbdc601251c9b9ce576b611d SHA512 9a6c30acb99c112497c02fb0826dc0197bbf4b813d25eab3f7d6537dfd83db8150c94f617f79810bbcca64496b8d6e67b1a41446523d66031c54c21e0425ea0c
DIST pycxx-7.1.2.tar.gz 150865 BLAKE2B bbf78d88ca13fafee1239c354167b56cef2f1d56d20b0fc81d9a5d7d82096ab5d6a88802f411719cc490179314f87ef89b1e53c2b8a3a784566f9ff9d16d7cc8 SHA512 67f8d8d1ec6ce63c39695cd56c3276767d5cb4b6cc2fcf7daf5aea4bac11114f5a1fa4784ecdb35be708859cf07fc88c8e9f00b7fc808169708fd0eef1056a63
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
deleted file mode 100644
index 5f6bfa74f4be..000000000000
--- a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -3,10 +3,18 @@
- from distutils.command.install import install
- from distutils.core import setup
-
--headers = (glob( os.path.join( "CXX","*.hxx" ) )
-- +glob( os.path.join( "CXX","*.h" ) ))
--sources = (glob( os.path.join( "Src", "*.cxx" ) )
-- +glob( os.path.join( "Src", "*.c" ) ))
-+headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
-+ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) ))
-+headers += [header for header in
-+ glob( os.path.join( "CXX", "*.hxx" ) ) +
-+ glob( os.path.join( "CXX", "*.h" ) )
-+ if os.path.sep.join((os.path.split(header)[0], "Python%s" % sys.version_info[0], os.path.split(header)[1])) not in headers]
-+sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
-+ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
-+sources += [source for source in
-+ glob( os.path.join( "Src", "*.cxx" ) ) +
-+ glob( os.path.join( "Src", "*.c" ) )
-+ if os.path.sep.join((os.path.split(source)[0], "Python%s" % sys.version_info[0], os.path.split(source)[1])) not in sources]
-
-
- class my_install (install):
diff --git a/dev-python/pycxx/pycxx-6.2.6.ebuild b/dev-python/pycxx/pycxx-6.2.6.ebuild
deleted file mode 100644
index 1baa0be8acc3..000000000000
--- a/dev-python/pycxx/pycxx-6.2.6.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-python_prepare_all() {
- # Without this, pysvn fails.
- # CXX/Python2/Config.hxx: No such file or directory
- sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
-
- # Remove python2 print statement
- echo > Lib/__init__.py || die
-
- local PATCHES=(
- "${FILESDIR}/${PN}-6.2.3-installation.patch"
- )
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( Doc/. )
- if use examples; then
- docinto examples
- dodoc -r Demo/Python{2,3}/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}