summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-01-02 15:27:03 -0600
committerTim Harder <radhermit@gentoo.org>2019-01-02 15:27:03 -0600
commit97142c6e2a787450d96a0c05dadfca1e42bc421c (patch)
treec2ae23469d7c509660590550a8bb5a82cf7d3ee8 /dev-python/pychroot
parentdev-python/snakeoil: remove old (diff)
downloadgentoo-97142c6e2a787450d96a0c05dadfca1e42bc421c.tar.gz
gentoo-97142c6e2a787450d96a0c05dadfca1e42bc421c.tar.bz2
gentoo-97142c6e2a787450d96a0c05dadfca1e42bc421c.zip
dev-python/pychroot: add py37 support
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 57a2af631a20..a59532024a50 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_COMPAT=( python3_{4,5,6,7} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -21,7 +21,7 @@ SLOT="0"
IUSE="test"
if [[ ${PV} == *9999 ]]; then
- RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
fi