summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-01-22 00:00:07 -0800
committerBrian Dolbec <dolsen@gentoo.org>2016-01-23 11:23:04 -0800
commitbae965f73a2419319c8010cf528a963957a4880c (patch)
treeac94fc7317dd9c259872774fa74bd729d1173936 /dev-python/pyGPG/pyGPG-0.2.ebuild
parentdev-python/ssl-fetch: Version bump (diff)
downloadgentoo-bae965f73a2419319c8010cf528a963957a4880c.tar.gz
gentoo-bae965f73a2419319c8010cf528a963957a4880c.tar.bz2
gentoo-bae965f73a2419319c8010cf528a963957a4880c.zip
dev-python/pyGPG: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pyGPG/pyGPG-0.2.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
new file mode 100644
index 000000000000..f2fb3818d1c3
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "This version includes a new gkeys-gpg command"
+ einfo "It can be used as an alternate gpg command for git"
+ einfo "It will set the correct keyring to verify signed commits"
+ einfo "provided the key it needs to verify against is part of the gkeys"
+ einfo "keyring system. It only works for verification, any other call "
+ einfo "to it will re-direct directly to the normal gpg command."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}