summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 23:36:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 00:13:54 +0100
commit885d1179fec7e089e8bd90859e2a8fc2af15fba5 (patch)
tree3aced0d17d9fde83e91b242f0c6d9ae3427201ab /dev-python/prettytable
parentdev-python/pytest-subtests: Bump to 0.7.0 (diff)
downloadgentoo-885d1179fec7e089e8bd90859e2a8fc2af15fba5.tar.gz
gentoo-885d1179fec7e089e8bd90859e2a8fc2af15fba5.tar.bz2
gentoo-885d1179fec7e089e8bd90859e2a8fc2af15fba5.zip
dev-python/prettytable: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 38327f8c32b8..e0241d681f74 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1 +1,2 @@
DIST prettytable-3.0.0.tar.gz 50012 BLAKE2B 9a1c57abf46fd00fa74022ad9a8bd19c5f501610ac4dcd806511f5cd9e0ab17cbf24ce90b8f1c3f98db5601e1df75cf57c7709c84e0c3b703ebe2d69f57294d3 SHA512 f7b03ee1c1371187708b1cd7724f1afead1249a796928d2abdce42fa834ee128e930f20aef1df579426c65f1fb574b1a831e521ade6e9e65977d5dd88bafc5af
+DIST prettytable-3.1.0.tar.gz 52695 BLAKE2B 0a1f60ebc27f495f54a645a0e4a363d4bd052933c9e8b66a9ba209f1357e3d50e817cf6384ec99038d13dce03f60b86ececab0e7a76319be9f67869892e56ec0 SHA512 0f1fe86412cc553ef74d264044fd1830c1d5de6914a5a3d7ba3c7e9c92ed5e7b00dcaed1654f819b6a5233b24dfc331453a4ebb86a3e11779ea9932059519a56
diff --git a/dev-python/prettytable/prettytable-3.1.0.ebuild b/dev-python/prettytable/prettytable-3.1.0.ebuild
new file mode 100644
index 000000000000..1396cbe52707
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest