summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 14:18:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:04:45 +0100
commit2480ddbcaf1ff52ef6a71e8c6f6a42eda999d4e9 (patch)
treeaf01b2f4c929ead17318974bbba3674ed997c1b5 /dev-python/prettytable
parentdev-python/astroid: Bump to 2.13.1 (diff)
downloadgentoo-2480ddbcaf1ff52ef6a71e8c6f6a42eda999d4e9.tar.gz
gentoo-2480ddbcaf1ff52ef6a71e8c6f6a42eda999d4e9.tar.bz2
gentoo-2480ddbcaf1ff52ef6a71e8c6f6a42eda999d4e9.zip
dev-python/prettytable: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 4524f2bd3cd5..15ce1fb497dc 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
DIST prettytable-3.5.0.gh.tar.gz 45387 BLAKE2B 0ddb2c89e80c8f713c01afd4db7d5fcfa8151bcfaf7dcf07d66898b1b868ca093931829fe1b4db96c120a6eda1f84580726931dbd6d49b9870c1fc1eb0e479b9 SHA512 24ef28a42365568bf68a974afd42fcc1bfb9208e1cb75fc1b2890bc2253487afa6536e778b58e320e952ca8bf9b69193bd1293bb7615628d03765ee24c44edff
+DIST prettytable-3.6.0.gh.tar.gz 46174 BLAKE2B 2a7e507efdf4ab3282e95e8db14b92477fdd40a06fdb009146ce6a3a52ef49e46a61803ac3cd85d2ec993ad8cc49bd842d438b97fc037e56cb33cd4495b535ef SHA512 b4693a3d30555f598cb955923560d02ce7c757e87ee49bf09c8d50d3ce8bef67ebfad1c780914f488e89852c0e363c2cad098addc058a88864efb8eefa8e9cd8
diff --git a/dev-python/prettytable/prettytable-3.6.0.ebuild b/dev-python/prettytable/prettytable-3.6.0.ebuild
new file mode 100644
index 000000000000..53c3c61e1d89
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+SRC_URI="
+ https://github.com/jazzband/prettytable/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}