summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 16:20:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 16:20:32 -0800
commit953833b903a1f2b0ba9c69971bacdc2bdd701cdc (patch)
tree3c85e5341cdd97e067b931b945664e866a7c249a /dev-python/portend
parentdev-python/tempora: Revbump to 1.14.1-r1, add py38 (diff)
downloadgentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.tar.gz
gentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.tar.bz2
gentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.zip
dev-python/portend: Version bump to 2.6, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-2.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index 0c788ac69e6e..a4b24829d8ee 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1 +1,2 @@
DIST portend-2.2.tar.gz 7974 BLAKE2B 77ffcf02b65f276a5ca1f1bdd76afd54e8f6afcb1c55b6948862017f973772dfe65c9b934ffbc98d2f36f799131d23d4a7128f46e46183010def8936f2dd0bad SHA512 1782132b0dec5b678892190b70ab795b1748dfa17e257b6655fc803f0cf19652725778cd329c3609353f969959501dd11fd2b9726cfcdf2c58689e2ce280c146
+DIST portend-2.6.tar.gz 12295 BLAKE2B 307bb77bb7d73e201f00ca203204149bb4fba8a00277da08f804626be4d01b15bdd38ade7a49c7acafd37263cad6e8c62e0eb6e6bdec0d9e10267c1fbf469aa9 SHA512 9e53c668ba9d0ddb2e92d9b4c97d2b8a4d858a6fc44123414ee3c8ac433f51f50a4773ee08f85bb134e49aeace2a17baffd32962d36df0b19b505a2c6634bf7e
diff --git a/dev-python/portend/portend-2.6.ebuild b/dev-python/portend/portend-2.6.ebuild
new file mode 100644
index 000000000000..3c1794c30ef8
--- /dev/null
+++ b/dev-python/portend/portend-2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
+
+ # avoid extra test deps
+ sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}