summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-04 08:55:56 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-04 08:59:30 +0200
commit551e06cfc6d0ecff8d4538f103fd3a51ad9bec6d (patch)
treef4ea3ff36607fc91c15b1265271469a7fa63f5fe /dev-python/polib
parentdev-libs/libbytesize: Added "python" USE flag (diff)
downloadgentoo-551e06cfc6d0ecff8d4538f103fd3a51ad9bec6d.tar.gz
gentoo-551e06cfc6d0ecff8d4538f103fd3a51ad9bec6d.tar.bz2
gentoo-551e06cfc6d0ecff8d4538f103fd3a51ad9bec6d.zip
dev-python/polib: EAPI-7 revbump. Added python3_7 support.
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/polib-1.1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.1.0-r1.ebuild b/dev-python/polib/polib-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..6873694edef0
--- /dev/null
+++ b/dev-python/polib/polib-1.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}