summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-10-05 13:24:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-30 09:48:54 +0200
commite97aa55358563ba4ed561fae1448988ca6c21738 (patch)
tree9c4db2dc475f489b40e434425742aa1699b8315e /dev-python/pgspecial
parentdev-python/hypothesis: Bump to 4.50.2 (diff)
downloadgentoo-e97aa55358563ba4ed561fae1448988ca6c21738.tar.gz
gentoo-e97aa55358563ba4ed561fae1448988ca6c21738.tar.bz2
gentoo-e97aa55358563ba4ed561fae1448988ca6c21738.zip
dev-python/pgspecial: bump to version 1.11.7.
Closes: https://bugs.gentoo.org/696642 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13154 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index db2a65c02605..3e29f80f793e 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1 +1,2 @@
DIST pgspecial-1.11.5.tar.gz 43649 BLAKE2B f9b8956cfcd81bba946e0323d584668c82e6fc18a0aa08012c3236636d0ad801f10f786b71707daadafc1274d5733adecf9233871b13bded8fe8e8f41fad0fc9 SHA512 984a09a10a705d91d9b97142eb2502b44b2a79d95cc1ed8596dd2f7f31515028f4c34cc54383d762a73fdefd6e59418f677b020181740b82cebb5d8e77bbc234
+DIST pgspecial-1.11.7.tar.gz 44874 BLAKE2B 2d3afd7983a31347a4b0f59fd095684c2fb83e85def027f633734a672c3df1ed21584e2620932efacbdc27a579ea35e810e727456191e02811c81e906373ac5b SHA512 dbcfe996cb67af292c90bec431d918c3e78aa4fb90fcbfc9d5ef36ed0c5c7de58505704df277b586990efcc7110e1395af1476003aafaf359257f0665e4d9a19
diff --git a/dev-python/pgspecial/pgspecial-1.11.7.ebuild b/dev-python/pgspecial/pgspecial-1.11.7.ebuild
new file mode 100644
index 000000000000..06f5ead2917f
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of postgres meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # tests/test_special.py require local postgres instance
+ pytest -vv tests/test_internal.py || die
+}