summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-12 17:23:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-12 17:48:04 +0200
commitfb8653a4cc68b080e5c1b2f104601b512314f21a (patch)
tree8275208c63ea1bba9d10da232457ea0354ff832c /dev-python/peewee
parentdev-python/coverage: Bump to 6.4.2 (diff)
downloadgentoo-fb8653a4cc68b080e5c1b2f104601b512314f21a.tar.gz
gentoo-fb8653a4cc68b080e5c1b2f104601b512314f21a.tar.bz2
gentoo-fb8653a4cc68b080e5c1b2f104601b512314f21a.zip
dev-python/peewee: Bump to 3.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.15.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 07470d60107a..100e853dfc85 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1,3 @@
DIST peewee-3.14.10.tar.gz 896121 BLAKE2B c6d42dbca418475325e704e86dbf1d420426b1276a63ad1d49f3361478325b5a4b01bcbd875b32439bb497c4e18248efa6fe44c589c3247ee84043ca1bfc1a74 SHA512 1f423097c67c6a3976ed77586e3ea9db6db42e3c18e6f4c6046176a0e8942a9ce228cefd2a09e39fde359479e70a04e4c06030682442d96657d24984666b13d1
DIST peewee-3.15.0.gh.tar.gz 903961 BLAKE2B d3e01171fb281c1b371bc6518366fec698144761d1a88da25200b8a68ab909ca195c7900cc9f7439456ac14472f4b611cdd6ffb512e2448192cb892fb514cc62 SHA512 63c7a765327aa89ec0cb1d6306fa121f25fba39c353b475d6be4c59a2f8cf99724c366a314c769dc78e3da453c888d48d4d6151647af1621cfa16aade7118e25
+DIST peewee-3.15.1.gh.tar.gz 903784 BLAKE2B 2570f12089728dd56bbcdf8715b7874fe11bed4790b80780b5850445188305a98695cbaac2e7a9b1cd53d9ae601a6a1be796219386dfa07da45610013151062d SHA512 eabfa7ae532fc6d392c7c89844ac28533787dd1a8e08ba797d6f0c5f70b9e60d74e3ca98e1a1e71e66744a7b48a3544c228289d7ac415619bfd81da15d6cf0fc
diff --git a/dev-python/peewee/peewee-3.15.1.ebuild b/dev-python/peewee/peewee-3.15.1.ebuild
new file mode 100644
index 000000000000..82b01219bc7a
--- /dev/null
+++ b/dev-python/peewee/peewee-3.15.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}