summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:09:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:26:03 +0200
commita366a9f3bdf2f17c6f02f7a09d9f1849bc27e088 (patch)
treef0b155beaa568c21406da1d6df1fd2a5dbab29ce /dev-python/peewee
parentdev-python/Faker: add 13.3.1 (diff)
downloadgentoo-a366a9f3bdf2f17c6f02f7a09d9f1849bc27e088.tar.gz
gentoo-a366a9f3bdf2f17c6f02f7a09d9f1849bc27e088.tar.bz2
gentoo-a366a9f3bdf2f17c6f02f7a09d9f1849bc27e088.zip
dev-python/peewee: add 3.14.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.14.10.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index bd00f7f2a7d9..a53b7dc2ab27 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
+DIST peewee-3.14.10.tar.gz 896121 BLAKE2B c6d42dbca418475325e704e86dbf1d420426b1276a63ad1d49f3361478325b5a4b01bcbd875b32439bb497c4e18248efa6fe44c589c3247ee84043ca1bfc1a74 SHA512 1f423097c67c6a3976ed77586e3ea9db6db42e3c18e6f4c6046176a0e8942a9ce228cefd2a09e39fde359479e70a04e4c06030682442d96657d24984666b13d1
DIST peewee-3.14.8.tar.gz 891123 BLAKE2B 67c64ad5c8ca52987c329592dc436e3c27db5b3baa7f7c68ee4fcb06e338e38a71bfce30dcd62b7562d85a3ab7fa554f1ba8093e9a59536ffb4289c186852853 SHA512 d736e5dfc139656cba7caf488d68907683893d5a2537f96269af9ed693ec79c089d2822d355be4a9c6136b5cd813b0cccf774afd585f9bd420d57a8700cabfbe
diff --git a/dev-python/peewee/peewee-3.14.10.ebuild b/dev-python/peewee/peewee-3.14.10.ebuild
new file mode 100644
index 000000000000..c471bcb506de
--- /dev/null
+++ b/dev-python/peewee/peewee-3.14.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}