summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-25 08:32:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-25 08:32:26 +0200
commit66527bd6069217dae749d6abb5fd3a26aca0885d (patch)
tree1035b94731f9685debc02138d614a24d6f9f48f1 /dev-python/peewee
parentdev-python/coverage: Stabilize 7.5.1 x86, #932694 (diff)
downloadgentoo-66527bd6069217dae749d6abb5fd3a26aca0885d.tar.gz
gentoo-66527bd6069217dae749d6abb5fd3a26aca0885d.tar.bz2
gentoo-66527bd6069217dae749d6abb5fd3a26aca0885d.zip
dev-python/peewee: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.17.3.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index d8b008aff269..9551a6e40ee4 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1 @@
-DIST peewee-3.17.3.gh.tar.gz 926892 BLAKE2B e5d378da37f7fda74c75d3c3998e3fae79e9b8c7d66ca5a17e76a7b855c9d7ae159b4eedb97f68c9ec13cf00f2268f425b36273e7b09fbd001364e748d13bc95 SHA512 d7d0c716c1b6600275c151894ea8738c3393e554627ae4d8cf0d52548be99cfaf31e5553f51762cedc7f9e66a779ddef60d305a3797e3db71ac1a2178bb45468
DIST peewee-3.17.5.gh.tar.gz 927674 BLAKE2B 45d23ebec38363a83441c916def460d76c7fe54175497df53de5a904d57b3d2cdbe077f757028b85f6a5eba0e65f1eab9ee99ceea11a00a9b111fce842ccd010 SHA512 b9878450a0759740f28cb6425ba0f14aa92e037bc4c888c13ae24bc38993787e64bff6342edcdf5364b5aac97c405e1c8e53e1140016e6bdbeba6d57d7f339ec
diff --git a/dev-python/peewee/peewee-3.17.3.ebuild b/dev-python/peewee/peewee-3.17.3.ebuild
deleted file mode 100644
index 2943c28f7f6b..000000000000
--- a/dev-python/peewee/peewee-3.17.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Small Python ORM"
-HOMEPAGE="
- https://github.com/coleifer/peewee/
- https://pypi.org/project/peewee/
-"
-SRC_URI="
- https://github.com/coleifer/peewee/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-IUSE="examples +native-extensions test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- native-extensions? ( dev-db/sqlite:3= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-db/postgresql
- dev-python/psycopg:0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme
-
-src_compile() {
- if ! use native-extensions; then
- local -x NO_SQLITE=1
- fi
-
- distutils-r1_src_compile
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- pg_ctl -w -D "${T}"/pgsql start -o "-h '' -k '${T}'" || die
- createdb -h "${T}" peewee_test || die
-
- local -x PEEWEE_PSQL_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && DOCS=( examples/ )
- distutils-r1_python_install_all
-}