summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-27 16:30:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-27 16:37:32 +0200
commit50f930e36f48cd7458e16b1f1cce376468e8d272 (patch)
tree73c8d89ad1719df5acfa0f450d74dbcd029be63d /dev-python/oslo-config
parentwww-apps/sonarr-bin: drop 4.0.9.2257 (diff)
downloadgentoo-50f930e36f48cd7458e16b1f1cce376468e8d272.tar.gz
gentoo-50f930e36f48cd7458e16b1f1cce376468e8d272.tar.bz2
gentoo-50f930e36f48cd7458e16b1f1cce376468e8d272.zip
dev-python/oslo-config: Bump to 9.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest1
-rw-r--r--dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch43
-rw-r--r--dev-python/oslo-config/oslo-config-9.6.0.ebuild63
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
index 16dd266ea64e..ddaed0ef51d9 100644
--- a/dev-python/oslo-config/Manifest
+++ b/dev-python/oslo-config/Manifest
@@ -1 +1,2 @@
DIST oslo.config-9.5.0.tar.gz 161655 BLAKE2B 7844729658ddd13ff89b4c14983cfeeb3f6352f99a190058bd924592d9183459ea2da5caead7a77ed6c4a4e395aac2dd53f56847d81ce911ce76a04fa69f5b7d SHA512 517bb9fe416451eb791087216facd8643d77affb738aa2623817302dfc9dbd242d1aa2ba8c542fee437f91b2049129fa097fe37fec8c6a28e0092fc4d64c0c4f
+DIST oslo.config-9.6.0.tar.gz 164859 BLAKE2B 251e75d3ed919f2fce1efcd3aa5695da6e7911972ac89065813ef0c5b2b96fc02c436362875bf965b70e149d4436080ab23092f8f17568324e30eec7befe25cb SHA512 ebf31035bdf6f4ac8a9ce6bef14ca52fcad4418696520f0c199058211dbaa37723273a7c07eded03b139426392d7df6b192381af23e2324a92632029b1031292
diff --git a/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch b/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch
new file mode 100644
index 000000000000..f105b7719199
--- /dev/null
+++ b/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch
@@ -0,0 +1,43 @@
+From 972d304bb23baef538ce759004410a20d8109ccb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 27 Aug 2024 15:54:45 +0200
+Subject: [PATCH] Fix test_sub_command_multiple on Python 3.12.5+
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Update the expectations in test_sub_command_multiple for different
+argparse error handling in Python 3.12.5 and newer. Previously,
+the 'cannot have multiple subparser arguments' error would be output
+to stderr and cause the parser to exit; now it raises an ArgumentError
+instead.
+
+Closes-Bug: 2074130
+Change-Id: I83de6b6943b14f1f6df86a55603e6867dce680d3
+Signed-off-by: Michał Górny <mgorny@gentoo.org>
+---
+ oslo_config/tests/test_cfg.py | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/oslo_config/tests/test_cfg.py b/oslo_config/tests/test_cfg.py
+index 1759ae7..383b70f 100644
+--- a/oslo_config/tests/test_cfg.py
++++ b/oslo_config/tests/test_cfg.py
+@@ -4385,8 +4385,12 @@ class SubCommandTestCase(BaseTestCase):
+ self.conf.register_cli_opt(cfg.SubCommandOpt('cmd1'))
+ self.conf.register_cli_opt(cfg.SubCommandOpt('cmd2'))
+ self.useFixture(fixtures.MonkeyPatch('sys.stderr', io.StringIO()))
+- self.assertRaises(SystemExit, self.conf, [])
+- self.assertIn('multiple', sys.stderr.getvalue())
++ if sys.version_info >= (3, 12, 5):
++ self.assertRaisesRegex(argparse.ArgumentError, 'multiple',
++ self.conf, [])
++ else:
++ self.assertRaises(SystemExit, self.conf, [])
++ self.assertIn('multiple', sys.stderr.getvalue())
+
+
+ class SetDefaultsTestCase(BaseTestCase):
+--
+2.46.0
+
diff --git a/dev-python/oslo-config/oslo-config-9.6.0.ebuild b/dev-python/oslo-config/oslo-config-9.6.0.ebuild
new file mode 100644
index 000000000000..764961e742d4
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-9.6.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.config/
+ https://github.com/openstack/oslo.config/
+ https://pypi.org/project/oslo.config/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ local PATCHES=(
+ # https://review.opendev.org/c/openstack/oslo.config/+/927273
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
+ # broken by some dep upgrade
+ sed -i -e '/DeprecationWarningTestsNoOsloLog/,$d' \
+ oslo_config/tests/test_cfg.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ eunittest -b
+}