summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-30 16:01:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-30 16:34:42 -0500
commitd801fb6fdbddd41f1144c4ea70c6933741900b97 (patch)
tree5d6a4692de0ea8054eb4631046a882829cfebdb9 /dev-python/os-brick
parentdev-python/os-xenapi: 0.3.3 bump for rocky (diff)
downloadgentoo-d801fb6fdbddd41f1144c4ea70c6933741900b97.tar.gz
gentoo-d801fb6fdbddd41f1144c4ea70c6933741900b97.tar.bz2
gentoo-d801fb6fdbddd41f1144c4ea70c6933741900b97.zip
dev-python/os-brick: 2.5.3 bump for pike
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/os-brick')
-rw-r--r--dev-python/os-brick/Manifest1
-rw-r--r--dev-python/os-brick/os-brick-2.5.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/os-brick/Manifest b/dev-python/os-brick/Manifest
index 171f8a49b595..1b9393e01a2f 100644
--- a/dev-python/os-brick/Manifest
+++ b/dev-python/os-brick/Manifest
@@ -1,3 +1,4 @@
DIST os-brick-1.15.5.tar.gz 161371 BLAKE2B 0fdfb5978cb1d1ca635d64f98b75210b03353c033affd9834294c4d505a0d9e580f0f829a5e5c96fdb53f1cf2a29ba63ded6fbba4ae662a5dad0d20fdf98356b SHA512 c73c0f227e68aeba80b6b5687fc876e7dfe3ba36a800b7241ed08a0f189e0a57adfdf3b3e1f63230514ddac848be84e1f05e6be6aa0f50412695c6d37124717d
DIST os-brick-2.3.1.tar.gz 166518 BLAKE2B d58acd3ffffa6a5ca328eda9f74f4e9897846b047fc96777fb438c5e5a2fbef642e1672bd7f216acddef29138543627ef79fb6e6fc01e9e7cb34ee59663bedd8 SHA512 243d574289a95a07c43b112f9c00372a8b95560628f1d86f3ea750755b4026ef9426864a216a459c159b7275218a08df585aaf0f4f3c973d63af5a59083a6b2b
DIST os-brick-2.3.3.tar.gz 166088 BLAKE2B d5bdb748f8cb00ceef7649198470be3beb58bc9824ce74d8781c65ad87125b5480dc22fa978817fb89842ed347fbe7f0d1a3b5c94642ca418b7c6a694423d56d SHA512 8373641ee102eb7e522da400dcd960672341828ce252610bc65b042e5d0e614ec8af29d8fc87564a29b62615d71aa8b1074b4155c8f70cf35232fb2b37105f94
+DIST os-brick-2.5.3.tar.gz 172125 BLAKE2B 3809301fad05883bd81510452189506a05561bdd1d95706df9690a5d0bcd3165ed9c55b06cbe4b3f24a4ee62877c784209b38348f224e6c82e5683133cc13d73 SHA512 b2f0b75f90ce973569c25ea18fd3b1372209a4f49572644fe1b99bf295edf8e1346624ce95eaebaa37653b7753169b42a054e5f9ea4763c35ade5003b8ef47b2
diff --git a/dev-python/os-brick/os-brick-2.5.3.ebuild b/dev-python/os-brick/os-brick-2.5.3.ebuild
new file mode 100644
index 000000000000..90a7f026acdb
--- /dev/null
+++ b/dev-python/os-brick/os-brick-2.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}