summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 02:55:51 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 02:57:53 -0500
commita0a1c200fe8d7fa95c56b278322377e767d151af (patch)
treebbac760b2d3e08fa90b242f37061cede48196779 /dev-python/os-brick/os-brick-0.5.0.ebuild
parentdev-python/oslo-reports: adding for openstack liberty (diff)
downloadgentoo-a0a1c200fe8d7fa95c56b278322377e767d151af.tar.gz
gentoo-a0a1c200fe8d7fa95c56b278322377e767d151af.tar.bz2
gentoo-a0a1c200fe8d7fa95c56b278322377e767d151af.zip
dev-python/os-brick: adding for openstack liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/os-brick/os-brick-0.5.0.ebuild')
-rw-r--r--dev-python/os-brick/os-brick-0.5.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/os-brick/os-brick-0.5.0.ebuild b/dev-python/os-brick/os-brick-0.5.0.ebuild
new file mode 100644
index 000000000000..233cec1d64cd
--- /dev/null
+++ b/dev-python/os-brick/os-brick-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}