summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-16 01:06:57 +0100
committerSam James <sam@gentoo.org>2024-06-16 01:06:57 +0100
commit7b005b8564d8f8fe41971bafdc9d2f88c009d720 (patch)
tree5672e899dd7f2e125d00071fa797beadeccdb560 /dev-python/numpy
parentdev-texlive/texlive-basic: Stabilize 2023_p59159-r4 ppc64, #934251 (diff)
downloadgentoo-7b005b8564d8f8fe41971bafdc9d2f88c009d720.tar.gz
gentoo-7b005b8564d8f8fe41971bafdc9d2f88c009d720.tar.bz2
gentoo-7b005b8564d8f8fe41971bafdc9d2f88c009d720.zip
dev-python/numpy: filter LTO, add bug references
Closes: https://bugs.gentoo.org/853901 Closes: https://bugs.gentoo.org/922457 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.26.4.ebuild3
-rw-r--r--dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-1.26.4.ebuild b/dev-python/numpy/numpy-1.26.4.ebuild
index dd1f528958aa..36d602fc4380 100644
--- a/dev-python/numpy/numpy-1.26.4.ebuild
+++ b/dev-python/numpy/numpy-1.26.4.ebuild
@@ -54,6 +54,9 @@ EPYTEST_XDIST=1
distutils_enable_tests pytest
python_prepare_all() {
+ # bug #922457
+ filter-lto
+ # https://github.com/numpy/numpy/issues/25004
append-flags -fno-strict-aliasing
distutils-r1_python_prepare_all
diff --git a/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild b/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild
index 7d3724a3aaa3..d33733489b22 100644
--- a/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild
+++ b/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild
@@ -57,6 +57,9 @@ python_prepare_all() {
"${FILESDIR}/${P}-gcc14.patch"
)
+ # bug #922457
+ filter-lto
+ # https://github.com/numpy/numpy/issues/25004
append-flags -fno-strict-aliasing
distutils-r1_python_prepare_all