summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-28 05:31:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-28 05:41:51 +0200
commit088c337bcbf81f57fe99d28836c1fcc8669b1c6e (patch)
tree0a86f870fc61f91a6e3b109f15b1f9b4603f4ce8 /dev-python/notebook
parentdev-python/openstackdocstheme: Bump to 3.3.0 (diff)
downloadgentoo-088c337bcbf81f57fe99d28836c1fcc8669b1c6e.tar.gz
gentoo-088c337bcbf81f57fe99d28836c1fcc8669b1c6e.tar.bz2
gentoo-088c337bcbf81f57fe99d28836c1fcc8669b1c6e.zip
dev-python/notebook: Bump to 7.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-7.2.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index 4d38801a4682..564d6424ece4 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1 +1,2 @@
DIST notebook-7.2.1.tar.gz 4946671 BLAKE2B 2f78c497b1527c29a911fd0a057df41f3e522e426e3eae940d9adea9f1df982b14c5bb61210357dfc271df51d2534f97408790bffb4e02ff2f12b33769f9836e SHA512 e11415139a21a7dd8692673c2011d11621881cd4b99f69de5f32c23161734b1620560f57654b2e57177cb3ba01152bb76e0c9f79c2f7924b0d8424c21c219677
+DIST notebook-7.2.2.tar.gz 4948876 BLAKE2B 2f145ee832e9eff647f7c736d116cbf684ae63948d8e2e1da2a1d8f2d1d3df23d198719bde9f8a705eb5b77b62dbd654e16ac4de658fbd4a9a809e37d3add8e4 SHA512 b18348e898f6135bea72e759a8137bf32f6ea79619388bd8b3627bd497746a233de69e1b7865bec473a7c49d65f22bc5755afbf79eeb1b4dbb7e0e3e8afe8e7f
diff --git a/dev-python/notebook/notebook-7.2.2.ebuild b/dev-python/notebook/notebook-7.2.2.ebuild
new file mode 100644
index 000000000000..49097b1c08f3
--- /dev/null
+++ b/dev-python/notebook/notebook-7.2.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/notebook/
+ https://pypi.org/project/notebook/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4.2.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-shim-0.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbval[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}