summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-12 20:04:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-12 20:04:48 +0200
commitd6f0cafa134055203ce87d9124eb395874e6ba8d (patch)
tree67e79a8a50e44dc14edd5a008484cb74c6e31fe9 /dev-python/munkres
parentnet-misc/bfgminer: last-rite (diff)
downloadgentoo-d6f0cafa134055203ce87d9124eb395874e6ba8d.tar.gz
gentoo-d6f0cafa134055203ce87d9124eb395874e6ba8d.tar.bz2
gentoo-d6f0cafa134055203ce87d9124eb395874e6ba8d.zip
dev-python/munkres: Fix tests on 32-bit platforms
Closes: https://bugs.gentoo.org/925702 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/munkres')
-rw-r--r--dev-python/munkres/files/munkres-1.1.4-test-32bit.patch34
-rw-r--r--dev-python/munkres/munkres-1.1.4-r1.ebuild5
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch b/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch
new file mode 100644
index 000000000000..86159299eed5
--- /dev/null
+++ b/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch
@@ -0,0 +1,34 @@
+From 380a0d593a0569a761c4a035edaa4414c3b4b31d Mon Sep 17 00:00:00 2001
+From: Stefano Rivera <stefano@rivera.za.net>
+Date: Sat, 17 Oct 2020 11:15:04 -0700
+Subject: [PATCH] Use a constant cost calculation in test_profit_float()
+
+Rather than an architecture-specific calculation, when our variable
+precision does not differ across architectures.
+
+Fixes: #40
+---
+ test/test_munkres.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/test_munkres.py b/test/test_munkres.py
+index 23796dd..3cc65d9 100644
+--- a/test/test_munkres.py
++++ b/test/test_munkres.py
+@@ -162,13 +162,13 @@ def test_profit_float():
+ [37.11, 53.12, 57.13, 78.14, 28.15],
+ [59.16, 43.17, 97.18, 88.19, 48.2],
+ [52.21, 19.22, 89.23, 60.24, 60.25]]
+- import sys
++ max_ = 2**32
+ cost_matrix = munkres.make_cost_matrix(
+- profit_matrix, lambda cost: sys.maxsize - cost
++ profit_matrix, lambda cost: max_ - cost
+ )
+ indices = m.compute(cost_matrix)
+ profit = sum([profit_matrix[row][column] for row, column in indices])
+- assert profit == pytest.approx(362.65)
++ assert profit == pytest.approx(392.65)
+
+ def test_irregular():
+ matrix = [[12, 26, 17],
diff --git a/dev-python/munkres/munkres-1.1.4-r1.ebuild b/dev-python/munkres/munkres-1.1.4-r1.ebuild
index 49df5c915ee2..7be785c8d94f 100644
--- a/dev-python/munkres/munkres-1.1.4-r1.ebuild
+++ b/dev-python/munkres/munkres-1.1.4-r1.ebuild
@@ -25,3 +25,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/bmc/munkres/pull/41
+ "${FILESDIR}/${P}-test-32bit.patch"
+)