summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-19 05:26:08 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-19 05:30:31 +0100
commit3fed1fae2b4af9133669f07c1ca94225001606c4 (patch)
tree30d2a3a5d3379a1d9b2e04e4150f57f2daca3027 /dev-python/mdit-py-plugins
parentdev-python/guessit: Bump to 3.7.0 (diff)
downloadgentoo-3fed1fae2b4af9133669f07c1ca94225001606c4.tar.gz
gentoo-3fed1fae2b4af9133669f07c1ca94225001606c4.tar.bz2
gentoo-3fed1fae2b4af9133669f07c1ca94225001606c4.zip
dev-python/mdit-py-plugins: Bump to 0.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest1
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index db230ae87e93..470ea8f2f7fb 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1 +1,2 @@
DIST mdit-py-plugins-0.3.3.gh.tar.gz 57366 BLAKE2B 60b53c6aa404a22296da122b6528491fa7dc52c4b485dea1b0c26c486cd04bf495948e03c40d54ac9d436431ab1154f51af90c84762f96d87984b74718a736a9 SHA512 a32a4a7004368af924c0876106e10a55a2f361a18db127a45080779bc39fb709ca274febbb4c4d5e872357e99bd8161e6c760783793516011da5f963368fa637
+DIST mdit-py-plugins-0.3.4.gh.tar.gz 59538 BLAKE2B 7046c2b8b5b117612a71c1a4894c7e3e49a161b5375fde13ec61c4a00c2bf5824505cb5639b70a3c58d7c9629e68bf794c950b5a28470392487965cd94f3e9a9 SHA512 e36b0ee0aca95d60c27a577e1c4bde9832d633ca84fb740f16a37dd63ece0a77005f8e3d03360ed0c92de57d3f656a8f76ab76642d8da3e5ac1d65384ee18d84
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild
new file mode 100644
index 000000000000..9dcd74e0c13e
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest