summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 21:48:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 23:15:08 +0200
commitec28cee5847352cbc26f833d313cf9ad13c9704f (patch)
tree6446c33fb84186a3d10c6c5ed189d60aff553416 /dev-python/marshmallow
parentdev-python/importlib_resources: Bump to 5.2.3 (diff)
downloadgentoo-ec28cee5847352cbc26f833d313cf9ad13c9704f.tar.gz
gentoo-ec28cee5847352cbc26f833d313cf9ad13c9704f.tar.bz2
gentoo-ec28cee5847352cbc26f833d313cf9ad13c9704f.zip
dev-python/marshmallow: Bump to 3.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.14.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index de34178426f2..9289aec04794 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.13.0.tar.gz 175134 BLAKE2B fc8ffb87ba31d5bd56c7ebf655824f59c78cea257a1b59de8a97be9f380367d4db428b6f4f93f81140cccd8274fee7946e466f87f7c31b6b9d39d5bb9fba3104 SHA512 e4425bfa26609c80bc581b60be5554effe4a57eafc36338dc672cb0b42fc14d788a1ef3b4506b6429bf8d235e6edb10925173c8414b2abca12a4c7bb5496ed53
+DIST marshmallow-3.14.0.tar.gz 175637 BLAKE2B 003bd5ee17d4c3db63fabcd75838f5455576eb8a741a0f1daba8c629ade145593538ba15d3ecd47d5b3cce65573f4ecd765c9badb0dd077c44b6d04537a1332f SHA512 3eed3cb7ba063c6a3503091b46443c6ad96f82e6c21e7ceb047b379dddad4429e59a8e5c828be258433b2743a8231bb338ef96f21767f17ed75fe44138bb0d64
diff --git a/dev-python/marshmallow/marshmallow-3.14.0.ebuild b/dev-python/marshmallow/marshmallow-3.14.0.ebuild
new file mode 100644
index 000000000000..7d3435061f3f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.14.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest