summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-21 04:50:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-21 05:13:54 +0200
commit8ac167bdbd5331b60cba1c93c16fd7598c5dd3b5 (patch)
tree124b50b64d52e73eefdc9e1944ac315b034614d8 /dev-python/marshmallow
parentdev-python/marshmallow: Remove old (diff)
downloadgentoo-8ac167bdbd5331b60cba1c93c16fd7598c5dd3b5.tar.gz
gentoo-8ac167bdbd5331b60cba1c93c16fd7598c5dd3b5.tar.bz2
gentoo-8ac167bdbd5331b60cba1c93c16fd7598c5dd3b5.zip
dev-python/marshmallow: Bump to 3.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.22.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 2e7efde8fe85..d9207dba98be 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.21.3.gh.tar.gz 183813 BLAKE2B c5b0165be783e87149c1f1b7f0e370c0c0b33cd5e34b0a91b1510b81e840ca1f87c34b13f00e0c22b5a34d8fec62bba4a66f889a450a4f03fda7a85a63bf71bf SHA512 522d015d4207b1258ef92901f106f94bd412e011c26ad074ca9ee3156e51a1d873063f0ebd24b613cd95f34397f29e79358bb420ee0eef51095e6e8858d61fca
+DIST marshmallow-3.22.0.gh.tar.gz 184804 BLAKE2B b877ad2b2bc1ad0c54c2a8fa9dd9eba393455dd8ce68fce574ffd11ec1e1cc0935c8296ddff9b53fb4f9e7618a8f4c2a13716e1c4a7c8bb1b1f17aa967d29009 SHA512 a4359eb2490e2bb8be6d0e31e1d8eabd2ebc19fa91d024335d2483dca77bb79848d4be13f1775fdabf97c6156a981260693234be45dd1ccd3567e9c79b981deb
diff --git a/dev-python/marshmallow/marshmallow-3.22.0.ebuild b/dev-python/marshmallow/marshmallow-3.22.0.ebuild
new file mode 100644
index 000000000000..f7d269422f0f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.22.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest