summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-21 07:38:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-21 08:06:48 +0200
commit3778084d8cfab0d34170049f47bdb5af6ab8c5bc (patch)
treea6cd664f344e79836da36260332e5008149f2ae0 /dev-python/marshmallow
parentdev-python/cfn-lint: Bump to 0.78.2 (diff)
downloadgentoo-3778084d8cfab0d34170049f47bdb5af6ab8c5bc.tar.gz
gentoo-3778084d8cfab0d34170049f47bdb5af6ab8c5bc.tar.bz2
gentoo-3778084d8cfab0d34170049f47bdb5af6ab8c5bc.zip
dev-python/marshmallow: Bump to 3.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.20.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 298f975b5165..73d811fa1bdc 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.19.0.gh.tar.gz 182305 BLAKE2B 2e37e0dcfcab3fa080745ccf6acbaf0fc71a43edfc9227ebf1d5320c61b0f0b51a0f3ea1d75ab1b213f8464d8ac043365ddadc8d9ab4479e21eed92ce5362b4e SHA512 e908ab33703fed5a9290189aa151dfdb425668bebe89063084f10435d2030927ce001c0d34d504d19998863431ded52a7a551085b11212489495d34aadb3b9e1
+DIST marshmallow-3.20.1.gh.tar.gz 183718 BLAKE2B f1e8011be42f6a94d8d2bfde70d2761b3a3efdbce1ca61445d11b8b1e2e2f79953abd4fcefcd9bfcb3370458c9bb0084a2697b8537af8f58d161bb0d19559170 SHA512 8d2eeadad42811b2311f70c8eb0101d88a53fa8d4216a2ab44e67a508f5514c65c35932e1d3d2000b5cbd77ee4aae2be0e29a82576c3917f5db640f4af078b53
diff --git a/dev-python/marshmallow/marshmallow-3.20.1.ebuild b/dev-python/marshmallow/marshmallow-3.20.1.ebuild
new file mode 100644
index 000000000000..6238f7c18ef0
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.20.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest