summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-07 07:54:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-07 08:33:30 +0200
commit1298e8dedbc68e306241c03d1c817ba4938380db (patch)
tree0ab3da5d1820358bbcf9d0767289d5f4c449e049 /dev-python/marshmallow
parentdev-python/apispec: Bump to 4.7.1 (diff)
downloadgentoo-1298e8dedbc68e306241c03d1c817ba4938380db.tar.gz
gentoo-1298e8dedbc68e306241c03d1c817ba4938380db.tar.bz2
gentoo-1298e8dedbc68e306241c03d1c817ba4938380db.zip
dev-python/marshmallow: Bump to 3.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.12.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 34e3ffbc41b3..5c02d8761dea 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,4 @@
DIST marshmallow-3.11.1.tar.gz 173844 BLAKE2B edd816ccd254dc52e01a2e067ff3037fa5206ae5badb1e9b46d83d3bdcd926d324c39321e4fa2b4fdf276158d36c2d3634086f76086dececaa24213bbb765e42 SHA512 ebb6b20ffc1b199408ede0c88d1512cada14cf7220315100398137b8374940c03dda2e6449ab9135963598ab321669068a9eca0e1c4cd2f3f2454eba19db04bd
DIST marshmallow-3.12.0.tar.gz 174790 BLAKE2B 07539540f361137dd2fa2d5c884e279137a82f69e8a9e294d6abe4c566c98f74a1836018618682ac0a08f1e0d1510dbffa6d9c030a98e2cba48230697742b7e3 SHA512 7b91ec42dffbb979bede21fbab17cfb081068eea54d02aaef991b58e884cc5675fb17d5f56278794e5c33960bf29951ba74533abb9a025228a524a4e413bd312
DIST marshmallow-3.12.1.tar.gz 174784 BLAKE2B d3540ba833950d730db719c8ac7e8d66a54a4b06d0decc161d9b1f82d2012db2df7cc376bf3fb322e8d07e60057409f2e6ab761561e822c942d189418c70b9fa SHA512 aadbf9c3b45a5b435ce7fd7f60a4318f393221f23687be7b48af43deee111f48806489169815122f297539614a81700a435cc579cf5b7d0fffea2a2809368db9
+DIST marshmallow-3.12.2.tar.gz 174529 BLAKE2B 67c8431c1b013f40c3ebbb23631be3060e978a4cb71f3802b810d943bb69fd32bea59b3b7c92df5ea3cbcef28ef7b64f32c9fb1a6a3d5d42e4eabd6ce4b7958e SHA512 d1f5e695564d0df10ec3f74b336b6ade7b247b722beea61a8cf10e30653745d187d26dcda3a2f2d38c04423315d20a67bc883c9e7b0d4686a759e379644cd457
diff --git a/dev-python/marshmallow/marshmallow-3.12.2.ebuild b/dev-python/marshmallow/marshmallow-3.12.2.ebuild
new file mode 100644
index 000000000000..7d3435061f3f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.12.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest