summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mamba
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mamba')
-rw-r--r--dev-python/mamba/Manifest4
-rw-r--r--dev-python/mamba/mamba-0.6.ebuild54
-rw-r--r--dev-python/mamba/mamba-0.8.2.ebuild54
-rw-r--r--dev-python/mamba/mamba-0.8.4.ebuild55
-rw-r--r--dev-python/mamba/mamba-0.8.ebuild53
-rw-r--r--dev-python/mamba/metadata.xml13
6 files changed, 233 insertions, 0 deletions
diff --git a/dev-python/mamba/Manifest b/dev-python/mamba/Manifest
new file mode 100644
index 000000000000..02d18f667f66
--- /dev/null
+++ b/dev-python/mamba/Manifest
@@ -0,0 +1,4 @@
+DIST mamba-0.6.tar.gz 12548 SHA256 94169b12141ba57bbcbc5a5fac810631102558450057e1b66b0631d521034b67 SHA512 1d29c90cb45d2a6881d3524517151b88c80acabeaecff42efa9c94a8257e726c4b53cc40aba0643e95ef4af7d2895cf49b6619df06e933aab88157105c98a8cb WHIRLPOOL 489769b4f4ae368d0fa9ce918b629ab661765e8e85f4de1fe609e6f85e19304ec2c3c41a278b47d205fbd42d44b625f8b16b09a223282031f0f317d622aa2481
+DIST mamba-0.8.2.tar.gz 13379 SHA256 4ece61321a90b904e8f2859f4966d3fd61b4161137e73d4a3f8015b6f1d944fd SHA512 3b8e824b5c84106462242404716a4b36c678878301a924c4118accedd1b6883e1102c3bc61ac200c78f64c3b6a6890ba0f5529c3cd4d6a2743189174aa2fd907 WHIRLPOOL 6a60c866c84140c82a57eec2341262fe9c8a3be900c4d8fecc3113c776b197ef9df378c73ef9c0e915ecf23f2ba31ec01c6e606cec30d7dcc0f9d7af6bc110a8
+DIST mamba-0.8.4.tar.gz 14781 SHA256 2fc3eb17a1d051438ca844ad9086f6ad8d27d7a262153cb9e740416b01b7d46d SHA512 31a58a6ee43500b6e059598ff45ffb0e89e385a10fc47a41222cce2a2fee3987bd84dc4484151d46a7062244437973afaddc2c74aa7df21c0e175a33ce8a630c WHIRLPOOL dc26692c8e46ab1f2226099b051fd1236fc7006b0f3ce93f70cca4a685c209e71de256ae6ed21695df9ccb299bf2edc1f9975c2f98ee906e8067ab3a9ccb2383
+DIST mamba-0.8.tar.gz 13192 SHA256 7e6488e41acecc08c8d729c18ef881a94119f575b1c7d365cc4ea3c3442aca63 SHA512 ac1c9342829d949bfbe99caa42403734a9965c6070fd95a7e427f7e2592c122d86eacd19b4c1ae566e7c3035a27a6c7e43ce0fb98d1a9b5c126ed75f1de314bc WHIRLPOOL 2d3b2895bbe4a6dd7e51d327e4e22a58874c4654ad52e589467c4f0eeda332855c1968d12fcfc32cdf28c8a9718fe3892b01b079b0efccc7efadd8e4a57d2ab7
diff --git a/dev-python/mamba/mamba-0.6.ebuild b/dev-python/mamba/mamba-0.6.ebuild
new file mode 100644
index 000000000000..bb85f66ee459
--- /dev/null
+++ b/dev-python/mamba/mamba-0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+EGIT_REPO_URI="https://github.com/nestorsalceda/mamba.git"
+
+DESCRIPTION="The definitive testing tool for Python. Born under the banner of Behavior Driven Development"
+HOMEPAGE="http://nestorsalceda.github.io/mamba"
+SRC_URI="https://github.com/nestorsalceda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ test? (
+ >=dev-python/sure-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/doublex-1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ~dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ ~dev-python/coverage-3.7[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-0.6.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ ebegin 'patching requirements.txt'
+ sed \
+ -e '3s/==/>=/' \
+ -i requirements.txt
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
+
+ distutils_install_for_testing
+
+ "${TEST_DIR}"/scripts/mamba || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/mamba/mamba-0.8.2.ebuild b/dev-python/mamba/mamba-0.8.2.ebuild
new file mode 100644
index 000000000000..0721779ad932
--- /dev/null
+++ b/dev-python/mamba/mamba-0.8.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="The definitive testing tool for Python. Born under the banner of Behavior Driven Development"
+HOMEPAGE="http://nestorsalceda.github.io/mamba"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/expects-0.4.2[${PYTHON_USEDEP}]
+ <dev-python/expects-0.5[${PYTHON_USEDEP}]
+ >=dev-python/doublex-expects-0.4[${PYTHON_USEDEP}]
+ <dev-python/doublex-expects-0.5[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ~dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7[${PYTHON_USEDEP}]
+ ~dev-python/watchdog-0.8.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ ebegin 'patching requirements.txt'
+ sed \
+ -e '2s/==/>=/' \
+ -i requirements.txt
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
+
+ distutils_install_for_testing
+
+ "${TEST_DIR}"/scripts/mamba || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/mamba/mamba-0.8.4.ebuild b/dev-python/mamba/mamba-0.8.4.ebuild
new file mode 100644
index 000000000000..72dd8a4455a9
--- /dev/null
+++ b/dev-python/mamba/mamba-0.8.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="The definitive testing tool for Python. Born under the banner of Behavior Driven Development"
+HOMEPAGE="http://nestorsalceda.github.io/mamba"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/doublex-expects-0.4[${PYTHON_USEDEP}]
+ <dev-python/doublex-expects-0.5[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4.2[${PYTHON_USEDEP}]
+ <dev-python/expects-0.5[${PYTHON_USEDEP}]
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ~dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7[${PYTHON_USEDEP}]
+ ~dev-python/watchdog-0.8.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ ebegin 'patching requirements.txt'
+ sed \
+ -e '2s/==/>=/' \
+ -i requirements.txt
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
+
+ distutils_install_for_testing
+
+ "${TEST_DIR}"/scripts/mamba || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/mamba/mamba-0.8.ebuild b/dev-python/mamba/mamba-0.8.ebuild
new file mode 100644
index 000000000000..67dee3e6867e
--- /dev/null
+++ b/dev-python/mamba/mamba-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The definitive testing tool for Python. Born under the banner of Behavior Driven Development"
+HOMEPAGE="http://nestorsalceda.github.io/mamba"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/expects-0.2.1[${PYTHON_USEDEP}]
+ ~dev-python/doublex-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ~dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ ~dev-python/coverage-3.7[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-0.6.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ ebegin 'patching requirements.txt'
+ sed \
+ -e '3s/==/>=/' \
+ -i requirements.txt
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
+
+ distutils_install_for_testing
+
+ "${TEST_DIR}"/scripts/mamba || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/mamba/metadata.xml b/dev-python/mamba/metadata.xml
new file mode 100644
index 000000000000..308165e71014
--- /dev/null
+++ b/dev-python/mamba/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">mamba</remote-id>
+ </upstream>
+</pkgmetadata>