summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 11:33:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 11:34:10 +0100
commit821bad62e5daab8aae03f55a63f5f86343296a89 (patch)
tree7e9681aa49f4e6e2ac579e263e592104ee851bc0 /dev-python/lz4
parentdev-python/pylama: Remove old (diff)
downloadgentoo-821bad62e5daab8aae03f55a63f5f86343296a89.tar.gz
gentoo-821bad62e5daab8aae03f55a63f5f86343296a89.tar.bz2
gentoo-821bad62e5daab8aae03f55a63f5f86343296a89.zip
dev-python/lz4: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/files/lz4-3.1.3-310-readall.patch32
-rw-r--r--dev-python/lz4/lz4-3.1.3.ebuild32
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index cb7e6eb4ec3d..412d75d8147d 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,2 +1 @@
DIST lz4-3.1.10.tar.gz 162886 BLAKE2B d87a84e619b62b0fb13c942c5bee1ba78c1457e1f8bef093d5be732ea6b1481ad1de38a3e3e9e3479fb407477d43183b376fd1ce2a2b5d6289d293a6c79dc414 SHA512 61983e77fa445f59503ccf8ed5fe0605d79754cdeb166e16a7093a856b23369634db7d105d57b3829e680dad0a3728adec9d18dccd92c994347b74c5af95580e
-DIST lz4-3.1.3.tar.gz 159016 BLAKE2B 2ab86799cbd37b96550ebb5d0e1a3c301cbcee2a42c6da189f5ae0fee4eb9c5614860dd044363e2c9312e3ab275eb527a116210604a72bd74354f49589d6567b SHA512 170b5330a8ec0eb4d69f3692c54eaa384fd4de78a7e7db95721d2f1e521ae9558f814e63bbb31db2775a81f7cd7eaea1420ad2c96406cff95d25bc5d30811aba
diff --git a/dev-python/lz4/files/lz4-3.1.3-310-readall.patch b/dev-python/lz4/files/lz4-3.1.3-310-readall.patch
deleted file mode 100644
index 63b306b4e4f3..000000000000
--- a/dev-python/lz4/files/lz4-3.1.3-310-readall.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/lz4/frame/__init__.py b/lz4/frame/__init__.py
-index 5fa03ce..b77c425 100644
---- a/lz4/frame/__init__.py
-+++ b/lz4/frame/__init__.py
-@@ -617,6 +617,17 @@ class LZ4FrameFile(_compression.BaseStream):
- # returns at least one byte (except at EOF)
- return self._buffer.peek(size)
-
-+ def readall(self):
-+ chunks = bytearray()
-+
-+ while True:
-+ data = self.read(io.DEFAULT_BUFFER_SIZE)
-+ chunks += data
-+ if not data:
-+ break
-+
-+ return bytes(chunks)
-+
- def read(self, size=-1):
- """Read up to ``size`` uncompressed bytes from the file.
-
-@@ -632,6 +643,9 @@ class LZ4FrameFile(_compression.BaseStream):
-
- """
- self._check_can_read()
-+
-+ if size < 0 and sys.version_info >= (3, 10):
-+ return self.readall()
- return self._buffer.read(size)
-
- def read1(self, size=-1):
diff --git a/dev-python/lz4/lz4-3.1.3.ebuild b/dev-python/lz4/lz4-3.1.3.ebuild
deleted file mode 100644
index b86d4cd56978..000000000000
--- a/dev-python/lz4/lz4-3.1.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="LZ4 Bindings for Python"
-HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="app-arch/lz4:="
-DEPEND=${RDEPEND}
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-310-readall.patch"
-)
-
-distutils_enable_tests pytest