summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-24 04:27:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-24 04:41:08 +0200
commit05c8836c84ad3d8f1ca5ea9c9440c18183e4670b (patch)
tree9e40e988c80387d6446f6cb828d5b8327c9fdb4a /dev-python/livereload
parentdev-python/autopep8: Bump to 2.3.1 (diff)
downloadgentoo-05c8836c84ad3d8f1ca5ea9c9440c18183e4670b.tar.gz
gentoo-05c8836c84ad3d8f1ca5ea9c9440c18183e4670b.tar.bz2
gentoo-05c8836c84ad3d8f1ca5ea9c9440c18183e4670b.zip
dev-python/livereload: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/livereload')
-rw-r--r--dev-python/livereload/Manifest1
-rw-r--r--dev-python/livereload/livereload-2.7.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/livereload/Manifest b/dev-python/livereload/Manifest
index 10bd270d011d..48fabe3856c8 100644
--- a/dev-python/livereload/Manifest
+++ b/dev-python/livereload/Manifest
@@ -1 +1,2 @@
DIST python-livereload-2.6.3.gh.tar.gz 29407 BLAKE2B 39f030dbc21bec1b132fd9d43f9072f4c35d23ccdca56819e2c6b35277e9eac9caeeff7052fc766359e34bf415319f809ebd45927bd2cc223be7ac88594feef7 SHA512 ccccb17cb4d835eb9e812f8076f871164f6afb2fdc1aee9e35c5ef2d75be2c0403cee51d4eb30b029d7b35522f357ee8c3e9df926fd93511ba7d010ed2a69e8e
+DIST python-livereload-2.7.0.gh.tar.gz 26138 BLAKE2B 4cb2fd5352cbb68f09c914000e37b8305d66c9735e232e5eccad3ea1016ffc6d3da0846ebce048385f6606ceaa176b8df77461d9a0ca939a2f65d089cec9c3e9 SHA512 676f50b9300e1582177493cef24f4e2b10a4e385d0de780bf9161dee66e3063420338021464477c8079bffd0e4690a4b0d15c71025ebf1959addbaa6e69fa8bb
diff --git a/dev-python/livereload/livereload-2.7.0.ebuild b/dev-python/livereload/livereload-2.7.0.ebuild
new file mode 100644
index 000000000000..6b966802b4a9
--- /dev/null
+++ b/dev-python/livereload/livereload-2.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-livereload-${PV}
+DESCRIPTION="livereload server in Python"
+HOMEPAGE="
+ https://github.com/lepture/python-livereload/
+ https://pypi.org/project/livereload/
+"
+SRC_URI="
+ https://github.com/lepture/python-livereload/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/tornado[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/myst-parser \
+ dev-python/sphinxcontrib-programoutput
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}