summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:29:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:24 +0100
commit1f9f1999cdc8ccb94054dec2d2951c7e486aa996 (patch)
tree083f072f5a45564fcf8937b43274d14b4d6a037e /dev-python/lit
parentMove {sys-devel → llvm-core}/llvm-common (diff)
downloadgentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.tar.gz
gentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.tar.bz2
gentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.zip
Move {sys-devel → llvm-core}/llvm
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-15.0.7.ebuild8
-rw-r--r--dev-python/lit/lit-16.0.6.ebuild6
-rw-r--r--dev-python/lit/lit-17.0.6.ebuild4
-rw-r--r--dev-python/lit/lit-18.1.8.ebuild4
-rw-r--r--dev-python/lit/lit-19.1.4.ebuild4
-rw-r--r--dev-python/lit/lit-19.1.5.ebuild4
-rw-r--r--dev-python/lit/lit-20.0.0.9999.ebuild4
-rw-r--r--dev-python/lit/lit-20.0.0_pre20241207.ebuild4
8 files changed, 19 insertions, 19 deletions
diff --git a/dev-python/lit/lit-15.0.7.ebuild b/dev-python/lit/lit-15.0.7.ebuild
index cb3bb23824a5..d696ebab1f65 100644
--- a/dev-python/lit/lit-15.0.7.ebuild
+++ b/dev-python/lit/lit-15.0.7.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 llvm.org
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
cd "${WORKDIR}" || die
diff --git a/dev-python/lit/lit-16.0.6.ebuild b/dev-python/lit/lit-16.0.6.ebuild
index df4775d49f21..3b91f7542af3 100644
--- a/dev-python/lit/lit-16.0.6.ebuild
+++ b/dev-python/lit/lit-16.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
cd "${WORKDIR}" || die
diff --git a/dev-python/lit/lit-17.0.6.ebuild b/dev-python/lit/lit-17.0.6.ebuild
index 24220a780e24..5b15c0e83655 100644
--- a/dev-python/lit/lit-17.0.6.ebuild
+++ b/dev-python/lit/lit-17.0.6.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test
diff --git a/dev-python/lit/lit-18.1.8.ebuild b/dev-python/lit/lit-18.1.8.ebuild
index 6b9e078a9f68..a003c1b88ba2 100644
--- a/dev-python/lit/lit-18.1.8.ebuild
+++ b/dev-python/lit/lit-18.1.8.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test
diff --git a/dev-python/lit/lit-19.1.4.ebuild b/dev-python/lit/lit-19.1.4.ebuild
index 6b9e078a9f68..a003c1b88ba2 100644
--- a/dev-python/lit/lit-19.1.4.ebuild
+++ b/dev-python/lit/lit-19.1.4.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test
diff --git a/dev-python/lit/lit-19.1.5.ebuild b/dev-python/lit/lit-19.1.5.ebuild
index 75b7c01e4ef3..0bc978b6c9d2 100644
--- a/dev-python/lit/lit-19.1.5.ebuild
+++ b/dev-python/lit/lit-19.1.5.ebuild
@@ -21,14 +21,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test
diff --git a/dev-python/lit/lit-20.0.0.9999.ebuild b/dev-python/lit/lit-20.0.0.9999.ebuild
index d862b4f8cd03..cb62066830d4 100644
--- a/dev-python/lit/lit-20.0.0.9999.ebuild
+++ b/dev-python/lit/lit-20.0.0.9999.ebuild
@@ -20,14 +20,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test
diff --git a/dev-python/lit/lit-20.0.0_pre20241207.ebuild b/dev-python/lit/lit-20.0.0_pre20241207.ebuild
index d862b4f8cd03..cb62066830d4 100644
--- a/dev-python/lit/lit-20.0.0_pre20241207.ebuild
+++ b/dev-python/lit/lit-20.0.0_pre20241207.ebuild
@@ -20,14 +20,14 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
+ llvm-core/llvm
)
"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
-# TODO: move the manpage generation here (from sys-devel/llvm)
+# TODO: move the manpage generation here (from llvm-core/llvm)
src_prepare() {
# flaky test