summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/libcloud
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/Manifest3
-rw-r--r--dev-python/libcloud/libcloud-0.14.1.ebuild50
-rw-r--r--dev-python/libcloud/libcloud-0.15.0.ebuild50
-rw-r--r--dev-python/libcloud/libcloud-0.15.1.ebuild50
-rw-r--r--dev-python/libcloud/metadata.xml5
5 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
new file mode 100644
index 000000000000..d08a5e6cded5
--- /dev/null
+++ b/dev-python/libcloud/Manifest
@@ -0,0 +1,3 @@
+DIST apache-libcloud-0.14.1.tar.bz2 546545 SHA256 8562fd79c8afc63dabc8f62b08f13a1b1f71644c08e47f913f8c942d2f48c1d0 SHA512 cb338e63aa1b3949ac16eee77df53499797c92ea9e30dccb2ed0c823636f8adda62673131c25bc5138839da2b7a3a8c895d0acaadeff087c756e43b9ae23f5d9 WHIRLPOOL 7e3d5991487ceb3312d46b54bb7e525431c611d003d19c3f05ef4261257127622f0787d55fe08dfd1b0419cc85820ad3c2d1d8f3228aa31e475f4242a1452be0
+DIST apache-libcloud-0.15.0.tar.bz2 571365 SHA256 fcfea13c73279aaa846bbc6a22dad37864b2314b8497a3a4994b2b0632cf0633 SHA512 b0e85dba0a70701784903510e6eed1ada082b02e989a6af43122e3eaaaeee1cbd5da59660e1e78877219798b50f395d02d0738ae983bd1665eba0984d737e16c WHIRLPOOL eae1dd98b931ea88431d34b18325a3f62ab076d52fbeedc9ee9507234133fc1d99eed4cd24a3411e50870008aad3233f5d715341e3c2444aac29c6c3e35299ed
+DIST apache-libcloud-0.15.1.tar.bz2 570953 SHA256 557e3f29e0ab1f19a31e858a8e802c822cb7f07df5edce029a1c67d2b0f30d15 SHA512 0cbc02c955cb91e135d73a5198ad216d0f91fa942b88dd1ffc1c46a487190f45500f003d2825cdb4f6c96c4ca7e5cf2681709769b0c2d8801b08e5a41b3d69b0 WHIRLPOOL 0143a7d2c337603f769bb2d3fd4fb98df18c82dfaa09c12fe481f18eb300c65d9efd4e18756d0c75a691b6d755fff0f62d41ccda3c9006955870fb8631d8366d
diff --git a/dev-python/libcloud/libcloud-0.14.1.ebuild b/dev-python/libcloud/libcloud-0.14.1.ebuild
new file mode 100644
index 000000000000..1730f1e01a69
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.14.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/libcloud/libcloud-0.15.0.ebuild b/dev-python/libcloud/libcloud-0.15.0.ebuild
new file mode 100644
index 000000000000..1730f1e01a69
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.15.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/libcloud/libcloud-0.15.1.ebuild b/dev-python/libcloud/libcloud-0.15.1.ebuild
new file mode 100644
index 000000000000..5c8a4977c6b8
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.15.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/libcloud/metadata.xml b/dev-python/libcloud/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/libcloud/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>