summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-06 07:12:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-06 08:06:05 +0100
commit74173f3928e38da93771290a1686adf527bac286 (patch)
tree6e6a41b29ad56aa177a3426ee542768ecb9d1018 /dev-python/jwcrypto
parentdev-python/cython: Bump to 3.0.9 (diff)
downloadgentoo-74173f3928e38da93771290a1686adf527bac286.tar.gz
gentoo-74173f3928e38da93771290a1686adf527bac286.tar.bz2
gentoo-74173f3928e38da93771290a1686adf527bac286.zip
dev-python/jwcrypto: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.5.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index f9034f78b10d..9d2f89de4df3 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1 +1,2 @@
DIST jwcrypto-1.5.4.gh.tar.gz 96607 BLAKE2B a1558c58c26e6ecb3747c6e7d554bd2100fd8f3c9c5804cf2a596c55920399e879dad267bcbc162aab0b956bde129cdb0090af98171eb7cb06970ed0964f47d9 SHA512 085adfd5f894ee8215c70371d2ebc2e97a38efb17be14ee8433858474df906ff963f243f669e209624e7ec78c1eb8b5ccc2077f0fc50b4e5eef25885e338b4e1
+DIST jwcrypto-1.5.5.gh.tar.gz 96792 BLAKE2B 3c85f62936da7b69ec5f2aa0452f9696a349288554626c98c9e1c0ef31b5e4098520a588bcacb0d3d34d47c35c8556728551804ea01cca747ceb5e3c15497014 SHA512 a69ae9323a6f6d66cf7f47b57106ca81446627926d0e39223bcde51a1b520b07de823b7c023b7ac3a53a539273a5155c0490e5b4309a6fb81bcefa3685b6258c
diff --git a/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild b/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild
new file mode 100644
index 000000000000..aa90a1f6e229
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-3.4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}