summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-30 09:07:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-30 09:25:33 +0100
commit8e4d567a50a382bba213a5d9b4160e1ac090f024 (patch)
treeaf321c13ad96e7a224ed5bf29be57b136d94ed34 /dev-python/jsonpickle
parentdev-python/sybil: Bump to 2.0.1 (diff)
downloadgentoo-8e4d567a50a382bba213a5d9b4160e1ac090f024.tar.gz
gentoo-8e4d567a50a382bba213a5d9b4160e1ac090f024.tar.bz2
gentoo-8e4d567a50a382bba213a5d9b4160e1ac090f024.zip
dev-python/jsonpickle: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.4.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index eb7c9eac04c4..0d00e1a606ab 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1 +1,2 @@
DIST jsonpickle-1.4.1.tar.gz 104564 BLAKE2B a3ad6f9c712f39153186b6ccdef515581012ad4ba1251dcb094074f2093eb4b158b9357bdf2e8668073cb21dc3bf6dd2fc3a0058c8597252c558a797432068b9 SHA512 ed6bf3472c59ba907a973c5c6f05de13dbfc75eef103796b8f8a63d388f769527f22667ca8761092d1649ff2caf5a73de0593e370df3e7fcabe06e73b265da35
+DIST jsonpickle-1.4.2.tar.gz 104745 BLAKE2B af12141c867cd3dbecace5b7bc637b554c51c245d4f584c4d94e73e694b74f66fc59a65a62b7a0af361a7a8010b9398a9b04ee838c4f76c168b21dba6f2c9542 SHA512 a6da661a69daefbc9393a4a4c88aa1da1b8bd687b6eeaed3d833ce1683bd1fa9d7943fdeecfe927e0492945ee2910b6f2d5e53ddb2b928b21f7b099ab79d45e9
diff --git a/dev-python/jsonpickle/jsonpickle-1.4.2.ebuild b/dev-python/jsonpickle/jsonpickle-1.4.2.ebuild
new file mode 100644
index 000000000000..0305f827e625
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-1.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl.
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+"
+# toml via setuptools_scm[toml]
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx "docs/source"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # too many dependencies
+ rm tests/pandas_test.py || die
+ sed -e '/pandas/ d' -i tests/runtests.py || die
+ # broken with gmpy
+ rm tests/ecdsa_test.py || die
+
+ sed -i -e 's:--flake8 --black --cov --cov-append::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv tests || die "Tests failed with ${EPYTHON}"
+}