summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-07 20:27:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-07 20:47:58 +0100
commit22bd9cbd7bb7839028396f6a1e549fe230adaac5 (patch)
tree3002c715d3cdb55231041f36db99b3dbc1fb4d42 /dev-python/jsonpickle
parentdev-python/jupyterlab: Remove old (diff)
downloadgentoo-22bd9cbd7bb7839028396f6a1e549fe230adaac5.tar.gz
gentoo-22bd9cbd7bb7839028396f6a1e549fe230adaac5.tar.bz2
gentoo-22bd9cbd7bb7839028396f6a1e549fe230adaac5.zip
dev-python/jsonpickle: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.0.2.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 2a77224dbdfb..39acf435721e 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1,2 +1 @@
-DIST jsonpickle-3.0.2.gh.tar.gz 258895 BLAKE2B 51af5841fada084c4fdb27d2d9c95ba0a790027d6a67b37bee6cbf9f256ee2778cffa38fd994de728b58c03536a07492335fbe6d4e7eed875561a3264232f81e SHA512 ed2552a68ca05a6e7e01169697c1c46735f99df95d126007ac02c0315b32da45ddbb1265ab53e39e9f4f1b54029a764cb50a05f31d773bda46f349f53929f888
DIST jsonpickle-3.0.3.gh.tar.gz 259093 BLAKE2B a281f2054a4b7d66c746abecebb06326682e365941cfb880426bafc3aa0156202463a222a5c24a8eed89eb16ed90d01f38fa9728385e301c62ce27ee6abac770 SHA512 c3576c80d727f7b4f43e993a1dc68b0194dc4308cab9c7a9e3bd7e220a51fe2c2524c02d6afb5c1ead3c37c02d10c1106e89650fe6e609b5052f2a367150e8d1
diff --git a/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild b/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
deleted file mode 100644
index 3d699d4d629e..000000000000
--- a/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="
- https://github.com/jsonpickle/jsonpickle/
- https://pypi.org/project/jsonpickle/
-"
-SRC_URI="
- https://github.com/jsonpickle/jsonpickle/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/gmpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- ' python3_{10..11})
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e 's:--cov::' pytest.ini || die
- distutils-r1_python_prepare_all
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # problem when pandas are built with Cython 3.0.0
- # https://github.com/jsonpickle/jsonpickle/issues/460
- tests/pandas_test.py::test_timedelta_index_roundtrip
- )
- local EPYTEST_IGNORE=(
- # unpackaged bson dependency
- tests/bson_test.py
- )
-
- if ! has_version "dev-python/gmpy[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=( jsonpickle/ext/gmpy.py )
- fi
- if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=( jsonpickle/ext/pandas.py )
- fi
-
- epytest
-}
-
-pkg_postinst() {
- # Unpackaged optional backends: yajl, demjson
- optfeature "encoding numpy-based data" dev-python/numpy
- optfeature "encoding pandas objects" dev-python/pandas
- optfeature "fast JSON backend" dev-python/simplejson
-}