summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-16 20:12:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-21 10:28:51 +0200
commit9f5f5905ea66ae7be2327ccd3f8f3689fa88f79c (patch)
tree3622741e88b49dc1cc37c40d7353e58f01e0edbc /dev-python/jsmin
parentdev-python/joblib: version bump. (diff)
downloadgentoo-9f5f5905ea66ae7be2327ccd3f8f3689fa88f79c.tar.gz
gentoo-9f5f5905ea66ae7be2327ccd3f8f3689fa88f79c.tar.bz2
gentoo-9f5f5905ea66ae7be2327ccd3f8f3689fa88f79c.zip
dev-python/jsmin: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/jsmin')
-rw-r--r--dev-python/jsmin/Manifest1
-rw-r--r--dev-python/jsmin/jsmin-2.2.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/jsmin/Manifest b/dev-python/jsmin/Manifest
index c9326a33a195..c75181a68382 100644
--- a/dev-python/jsmin/Manifest
+++ b/dev-python/jsmin/Manifest
@@ -1 +1,2 @@
DIST jsmin-2.2.1.tar.gz 12542 BLAKE2B 17586d8f9f7a5725a8fcae041a63fcf0d7a297fedc19271a1db417b1f847abfa30477d256aed474fca73e9e1484b47368458bfe2469dd5166b9b25535cbd4c10 SHA512 b70a72d5dbe37b34cac186967b151a79573bc060a1b814645b6d58499ec0e087f7a5941b00755258cb05e8a092f05b614de1253038140e773102f5312fa6a3c7
+DIST jsmin-2.2.2.tar.gz 12705 BLAKE2B ff14d28c753443c4a17e19b7205b739d5a177eeb8074e4b16c7ae7e5f816758e1f54e07ceddf90dde70cc2752f9dadee0dc71754b2de3343256f3b1695187bba SHA512 e4fea940d7b5e1c0d7dacad70d90a242a8ba178423c886eb60ed7a36b1fba9ca67b5118f26e9a96058b86d3f612d40a21e62cdccd5858a2012a8f222fad3277d
diff --git a/dev-python/jsmin/jsmin-2.2.2.ebuild b/dev-python/jsmin/jsmin-2.2.2.ebuild
new file mode 100644
index 000000000000..6aba296c0296
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://pypi.org/project/jsmin/ https://github.com/tikitu/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m ${PN}.test || die
+}