summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-29 07:50:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-29 08:16:59 +0200
commit06f5dc2259423bea252868f68eea89b9569d3260 (patch)
treeb5f5b6f97cdafbff0c1a580350cba60a686532a1 /dev-python/jaraco-path/jaraco-path-3.4.0.ebuild
parentdev-python/node-semver: Bump to 0.8.1 (diff)
downloadgentoo-06f5dc2259423bea252868f68eea89b9569d3260.tar.gz
gentoo-06f5dc2259423bea252868f68eea89b9569d3260.tar.bz2
gentoo-06f5dc2259423bea252868f68eea89b9569d3260.zip
dev-python/jaraco-path: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-path/jaraco-path-3.4.0.ebuild')
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild b/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild
new file mode 100644
index 000000000000..0d9a9d13f611
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-8.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}