summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-07 09:11:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 10:26:38 +0100
commit7de3622445f6b4deb88cbd3a8659e0c7b4152bb8 (patch)
treed06b362cacadc0909afc1b8dc5fb96f83dc50bf1 /dev-python/jaraco-logging
parentdev-python/jaraco-itertools: Use pypi.eclass (diff)
downloadgentoo-7de3622445f6b4deb88cbd3a8659e0c7b4152bb8.tar.gz
gentoo-7de3622445f6b4deb88cbd3a8659e0c7b4152bb8.tar.bz2
gentoo-7de3622445f6b4deb88cbd3a8659e0c7b4152bb8.zip
dev-python/jaraco-logging: Switch to PyPI sdist
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/Manifest2
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild12
2 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
index 481c6361f06b..7859a90be423 100644
--- a/dev-python/jaraco-logging/Manifest
+++ b/dev-python/jaraco-logging/Manifest
@@ -1 +1 @@
-DIST jaraco.logging-3.1.2.gh.tar.gz 7193 BLAKE2B fab2b65f2cc40d96df1a145bd047aecfca9af8c54c438ec40f965c8698d5db328591c7857390638b6bb48d2faae5cd1ad4541f6eb7c3b85a7ca06d257ad15c98 SHA512 deebf628dd62b6948cdf12931018407de1fb653279e57efce0df1acdf11e4ebab33840ef1e1e452b711ddc70b62fe925ebaf49e065d3450a96f8f6c8bbb0120c
+DIST jaraco.logging-3.1.2.tar.gz 8107 BLAKE2B add8236bdf345d55186d8ab7432c2b392df6921229c23c253a3b224d0362073c417cd4c0540e28117a1331adea15d4e8a17ad72c2cf7084375a19c64c529ccc0 SHA512 d6d26364e44be089616913938d200f26c9da269853d673f1518c3e29905961dda264b95e60a7051e4e0d6b873eb9b65faefa9962a48e2cad43435ca32ef0e1f3
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
index 9a59eed8640b..fc057468aa67 100644
--- a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
@@ -6,19 +6,15 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P="${P/-/.}"
DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
HOMEPAGE="
https://github.com/jaraco/jaraco.logging/
https://pypi.org/project/jaraco.logging/
"
-SRC_URI="
- https://github.com/jaraco/jaraco.logging/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
+SRC_URI="$(pypi_sdist_url "${PN/-/.}")"
+S=${WORKDIR}/${P/-/.}
LICENSE="MIT"
SLOT="0"
@@ -33,8 +29,6 @@ BDEPEND="
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
python_test() {
# create a pkgutil-style __init__.py in order to fix pytest's
# determination of package paths