summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:16:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:48 +0200
commitcd0d02f7b97e37263d7617e05f3b156118572efe (patch)
tree2888dc41d26954fdff6bbe2e3687eca2cc6325b7 /dev-python/irc
parentdev-python/jupyter-server: Bump to 2.14.2 (diff)
downloadgentoo-cd0d02f7b97e37263d7617e05f3b156118572efe.tar.gz
gentoo-cd0d02f7b97e37263d7617e05f3b156118572efe.tar.bz2
gentoo-cd0d02f7b97e37263d7617e05f3b156118572efe.zip
dev-python/irc: Bump to 20.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-20.4.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 700bc270c538..76913e2f1737 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1,2 +1,3 @@
DIST irc-20.4.1.tar.gz 91229 BLAKE2B 05518a19821016e5a10173a5ee20a0d3cb6047eb87f4a153331bc8458abb365d27cde8ae02b1e7c12a86957adc7811511f61c516bdb1c6f0f03f4a5186524eb5 SHA512 e57e18c7c8111c883737cbaa176e0e895c182e43208ff784abf382bcab0b613287076ec35cfe266d78418e27b38a6443344b03bd90ea768c1c50ce0c32453d89
DIST irc-20.4.2.tar.gz 91206 BLAKE2B 4a2b16581bc863774180e9fe67b564be50cfa3ea192999153426bbe883b5360ccaf053fab6e7a9fb47262d0a7f3f97a2dd2eab8f2a6f16223e4fd12b0f333f45 SHA512 18a767ad99cbc387b9c785da9334a96822092eb90e7fdb913af92cb7ea973fc2e54cb59942a025e33630ff3a78b6a52910a92c053daa4f25ef37d851f58a62e4
+DIST irc-20.4.3.tar.gz 91219 BLAKE2B 8a18c569489f8b4cbc6d631aad410705f3b27d764c7acfc862daeb57626cc7677e6b3f7192fc0cfc8f1d3882f2cc200d4895192282e98aa428ca82286020cf95 SHA512 233e6a57435194de4365fe619c43316c5ff588b1ccda16351af841469d5902e9217911c50a464bc12ffd6b7dd5cbc5ff77ab5650d1beb73bc59a0d39b3436725
diff --git a/dev-python/irc/irc-20.4.3.ebuild b/dev-python/irc/irc-20.4.3.ebuild
new file mode 100644
index 000000000000..0a2a0ab2df22
--- /dev/null
+++ b/dev-python/irc/irc-20.4.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="
+ https://github.com/jaraco/irc/
+ https://pypi.org/project/irc/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ dev-python/jaraco-stream[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-text-3.10[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ dodoc -r scripts
+ fi
+ distutils-r1_python_install_all
+}