summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-18 07:06:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-18 07:06:34 +0100
commita7942b4794cc924fc76722e93c6068a21b893c7e (patch)
tree2880fab51ae010f525c34d3a027d21465ba7259e /dev-python/ini2toml
parentdev-python/argcomplete: Bump to 2.1.2 (diff)
downloadgentoo-a7942b4794cc924fc76722e93c6068a21b893c7e.tar.gz
gentoo-a7942b4794cc924fc76722e93c6068a21b893c7e.tar.bz2
gentoo-a7942b4794cc924fc76722e93c6068a21b893c7e.zip
dev-python/ini2toml: Bump to 0.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/ini2toml-0.12.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index fba01729057a..9d29bdceceaf 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1 +1,2 @@
DIST ini2toml-0.11.3.gh.tar.gz 94011 BLAKE2B c827b4030f7c80fa749cdccc170dfced7c869836c90e3350e486be94a30541983c79161e6fb4b007258a692abd62e8b724ac758f6c952b0c7b820e9b5679706d SHA512 f1331bc47a2d4593788de9d8b1fdbc2231ac22524aaf3a83695c810e0dcbdce4bb46c48363ea150a583e4b24264d7a25f85ece737b31fa0ec0b8a6a2e098a9d5
+DIST ini2toml-0.12.tar.gz 101098 BLAKE2B 8e44600718318ce9c2ebaa5205864c1ca6ce87852a59496801578f32e223b9283d2f724acf004136743f87c8a081e58fd1176abe85288f8c463fc2520f708633 SHA512 c324a65fa20af880f2731b740dbf041ef7673d7ab817a9ee1947bf781d39bc000fcd8a725a546fc6af0dbecd0ec0534b2f9b83f3d8ab4afc0239d94acca06df5
diff --git a/dev-python/ini2toml/ini2toml-0.12.ebuild b/dev-python/ini2toml/ini2toml-0.12.ebuild
new file mode 100644
index 000000000000..b796d712c588
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}