summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 07:53:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 08:06:23 +0200
commit3ab21cd91067cb06759b65aa51f2fa7266e2302e (patch)
tree1021949c92e9a06d7090cbb1185f7a3eed948b28 /dev-python/ijson
parentdev-python/mysqlclient: Bump to 2.2.0 (diff)
downloadgentoo-3ab21cd91067cb06759b65aa51f2fa7266e2302e.tar.gz
gentoo-3ab21cd91067cb06759b65aa51f2fa7266e2302e.tar.bz2
gentoo-3ab21cd91067cb06759b65aa51f2fa7266e2302e.zip
dev-python/ijson: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.2.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 2b546a9b7eaa..f27deb1e8bf6 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1,2 +1,3 @@
DIST ijson-3.2.0.post0.gh.tar.gz 127558 BLAKE2B 38e06039bb177c43e4744f145fed2159e317a0b8da628b85a62215cdfe6693b271c39629811513d2e563b532244950616b9105134916bc577446a0b5e5ce25f7 SHA512 b926253a3d6a070e2ac27c61542d340e4a1498de7642957dbe59e9fd3c53d700ed4e8ee71c83efcb90b2c302d15b0d268c38054c10728bbb436521aa5b42050b
DIST ijson-3.2.1.gh.tar.gz 127577 BLAKE2B 1b3c8ce6d8b01d0cf4af4d8995bcc33d879321ed5b89c4b6baa84ef10cd311a1e66254113a17229c228c26e2b996a52c4b0629b42dbd830f296fd4903b603468 SHA512 2bd3a978016fbbd3f5aca6644778d19478a561f40729206eaa4f14e30fde4ff3b92c8aa33c928cb9e81c678a5a84fa59ab68e747421d725e77c79a9c987e4536
+DIST ijson-3.2.2.gh.tar.gz 127965 BLAKE2B 2e20f7cc822406fe3e7eec99c3ef394e42d90b0b518226a7b8eb078763cb8317acb4a28934301116c32a2a9cc37403c2950b18232800485b1ea1206dace7ff23 SHA512 5935071bd0d3eecc39b3c30ca5cb2a959e4d455c57e36414d5c97ba71bbcf1a0b53c8b8afed7551a3a4ac4595294105566c9d7501b35832dd7e46a1bb2151287
diff --git a/dev-python/ijson/ijson-3.2.2.ebuild b/dev-python/ijson/ijson-3.2.2.ebuild
new file mode 100644
index 000000000000..f4e7d80ec763
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+SRC_URI="
+ https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x IJSON_BUILD_YAJL2C=1
+ # The extension is broken on PyPy3, probably a bug in PyPy itself.
+ # https://github.com/ICRAR/ijson/issues/101
+ [[ ${EPYTHON} == pypy3 ]] && IJSON_BUILD_YAJL2C=0
+ distutils-r1_python_compile
+}
+
+python_test() {
+ rm -rf ijson || die
+ epytest
+}