summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-02 17:15:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-02 17:15:54 +0200
commitbf8c821587396b3d74ae78b54272e6f78abe055d (patch)
treeb36a46277dc224f0111028f74dc6fa39f73e7ff9 /dev-python/httpbin
parentdev-python/httpbin: Keyword 0.10.1-r1 ia64, #912056 (diff)
downloadgentoo-bf8c821587396b3d74ae78b54272e6f78abe055d.tar.gz
gentoo-bf8c821587396b3d74ae78b54272e6f78abe055d.tar.bz2
gentoo-bf8c821587396b3d74ae78b54272e6f78abe055d.zip
dev-python/httpbin: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest1
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch43
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch31
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-test-werkzeug.patch19
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-werkzeug-2.1.patch32
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r6.ebuild60
6 files changed, 0 insertions, 186 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index 41a187504240..0dc9fe2291fa 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -1,2 +1 @@
DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
-DIST httpbin-0.7.0.tar.gz 92613 BLAKE2B 59252df1d4d0ef853ec65263b472d3ba6c597336d844f9b457f2d0a009048d4222f715a7f6fb120aca00fa641d1687e302036dc151bd2fd67ba98cf5fc47a63a SHA512 82e80058b58943637e9f8191764cea79bf7a6e40f36069f9b5d3f908585dbef20a03ef070d1f865d350920b6e874a93a48a544b05c14ff4911038ec2c20f6f63
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch b/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch
deleted file mode 100644
index 8031ad72de5b..000000000000
--- a/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 69d1e62e69b7f886ebbb41b8e9aae62e76adf375 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 2 Dec 2020 10:42:52 +0100
-Subject: [PATCH] Replace brotlipy with brotlicffi
-
-The brotlipy package has been renamed to brotlicffi. Update the imports
-and dependencies accordingly. The major advanage of the new package
-is that it no longer collides with the Python bindings provided
-by brotli itself.
----
- httpbin/filters.py | 2 +-
- setup.py | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/httpbin/filters.py b/httpbin/filters.py
-index c6268b6..4deeaaa 100644
---- a/httpbin/filters.py
-+++ b/httpbin/filters.py
-@@ -10,7 +10,7 @@ This module provides response filter decorators.
- import gzip as gzip2
- import zlib
-
--import brotli as _brotli
-+import brotlicffi as _brotli
-
- from six import BytesIO
- from decimal import Decimal
-diff --git a/setup.py b/setup.py
-index 7f9956b..8e17ef3 100644
---- a/setup.py
-+++ b/setup.py
-@@ -34,7 +34,7 @@ setup(
- packages=find_packages(),
- include_package_data = True, # include files listed in MANIFEST.in
- install_requires=[
-- 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
-+ 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlicffi',
- 'werkzeug>=0.14.1'
- ],
- )
---
-2.29.2
-
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
deleted file mode 100644
index 5d626768bd27..000000000000
--- a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -dupr a/httpbin/core.py b/httpbin/core.py
---- a/httpbin/core.py 2018-05-08 13:41:03.000000000 +0200
-+++ b/httpbin/core.py 2019-11-22 15:07:27.516500217 +0100
-@@ -21,7 +21,6 @@ from werkzeug.datastructures import WWWA
- from werkzeug.http import http_date
- from werkzeug.wrappers import BaseResponse
- from werkzeug.http import parse_authorization_header
--from raven.contrib.flask import Sentry
-
- from . import filters
- from .helpers import get_headers, status_code, get_dict, get_request_range, check_basic_auth, check_digest_auth, \
-@@ -58,6 +57,7 @@ app.debug = bool(os.environ.get('DEBUG')
-
- # Send app errors to Sentry.
- if 'SENTRY_DSN' in os.environ:
-+ from raven.contrib.flask import Sentry
- sentry = Sentry(app, dsn=os.environ['SENTRY_DSN'])
-
- # Set up Bugsnag exception tracking, if desired. To use Bugsnag, install the
-diff --git a/setup.py b/setup.py
-index 7f9956b..3cab2ae 100644
---- a/setup.py
-+++ b/setup.py
-@@ -35,6 +35,6 @@ setup(
- include_package_data = True, # include files listed in MANIFEST.in
- install_requires=[
- 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
-- 'raven[flask]', 'werkzeug>=0.14.1'
-+ 'werkzeug>=0.14.1'
- ],
- )
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-test-werkzeug.patch b/dev-python/httpbin/files/httpbin-0.7.0-test-werkzeug.patch
deleted file mode 100644
index 956a2f5235ca..000000000000
--- a/dev-python/httpbin/files/httpbin-0.7.0-test-werkzeug.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -dupr a/test_httpbin.py b/test_httpbin.py
---- a/test_httpbin.py 2019-11-22 15:06:56.199774070 +0100
-+++ b/test_httpbin.py 2019-11-22 15:18:58.010069445 +0100
-@@ -144,7 +144,6 @@ class HttpbinTestCase(unittest.TestCase)
- data = json.loads(response.data.decode('utf-8'))
- self.assertEqual(data['args'], {})
- self.assertEqual(data['headers']['Host'], 'localhost')
-- self.assertEqual(data['headers']['Content-Length'], '0')
- self.assertEqual(data['headers']['User-Agent'], 'test')
- # self.assertEqual(data['origin'], None)
- self.assertEqual(data['url'], 'http://localhost/get')
-@@ -158,7 +157,6 @@ class HttpbinTestCase(unittest.TestCase)
- data = json.loads(response.data.decode('utf-8'))
- self.assertEqual(data['args'], {})
- self.assertEqual(data['headers']['Host'], 'localhost')
-- self.assertEqual(data['headers']['Content-Length'], '0')
- self.assertEqual(data['url'], 'http://localhost/anything/foo/bar')
- self.assertEqual(data['method'], 'GET')
- self.assertTrue(response.data.endswith(b'\n'))
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-werkzeug-2.1.patch b/dev-python/httpbin/files/httpbin-0.7.0-werkzeug-2.1.patch
deleted file mode 100644
index cf7871268d99..000000000000
--- a/dev-python/httpbin/files/httpbin-0.7.0-werkzeug-2.1.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5cc81ce87a3c447a127e4a1a707faf9f3b1c9b6b Mon Sep 17 00:00:00 2001
-From: Maximino BOGADO <bogamax2@hotmail.fr>
-Date: Wed, 30 Mar 2022 16:26:31 +0200
-Subject: [PATCH] Replace BaseResponse to Response class (new werkzeug version
- 2.1.0)
-
----
- httpbin/core.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/httpbin/core.py b/httpbin/core.py
-index 305c9882..2bad408e 100644
---- a/httpbin/core.py
-+++ b/httpbin/core.py
-@@ -29,7 +29,7 @@
- from six.moves import range as xrange
- from werkzeug.datastructures import WWWAuthenticate, MultiDict
- from werkzeug.http import http_date
--from werkzeug.wrappers import BaseResponse
-+from werkzeug.wrappers import Response
- from werkzeug.http import parse_authorization_header
- from flasgger import Swagger, NO_SANITIZER
-
-@@ -77,7 +77,7 @@ def jsonify(*args, **kwargs):
-
-
- # Prevent WSGI from correcting the casing of the Location header
--BaseResponse.autocorrect_location_header = False
-+Response.autocorrect_location_header = False
-
- # Find the correct template folder when running from a different location
- tmpl_dir = os.path.join(os.path.dirname(os.path.abspath(__file__)), "templates")
diff --git a/dev-python/httpbin/httpbin-0.7.0-r6.ebuild b/dev-python/httpbin/httpbin-0.7.0-r6.ebuild
deleted file mode 100644
index b905561d50cc..000000000000
--- a/dev-python/httpbin/httpbin-0.7.0-r6.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="
- https://github.com/postmanlabs/httpbin/
- https://pypi.org/project/httpbin/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/werkzeug-3[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- # do not import raven if it's not going to be used
- # (upstream removed it completely in git anyway)
- "${FILESDIR}"/${P}-optional-raven.patch
- # fix tests with new versions of werkzeug
- "${FILESDIR}"/${P}-test-werkzeug.patch
- # use brotlicffi instead of brotlipy
- "${FILESDIR}"/${P}-brotlicffi.patch
- # fix compat with werkzeug 2.1
- # https://github.com/postmanlabs/httpbin/pull/674
- "${FILESDIR}"/${P}-werkzeug-2.1.patch
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # a new version of flask or whatever converts relative redirects
- # to absolute; this package is dead anyway, so just skip
- # the relevant tests
- sed -e 's:test_redirect:_&:' \
- -e 's:test_relative:_&:' \
- -i test_httpbin.py || die
- # broken
- sed -e 's:test_digest_auth:_&:' \
- -e 's:test_base64:_&:' \
- -i test_httpbin.py || die
-
- distutils-r1_src_prepare
-}