summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 06:03:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 06:03:05 +0200
commitb5f4347bffcdb09bea028ac682f8e65eccb9201f (patch)
tree46f3e669c06b8be6331613d0d974f7f33c072425 /dev-python/httpbin
parentdev-python/sqlglot: Bump to 17.16.2 (diff)
downloadgentoo-b5f4347bffcdb09bea028ac682f8e65eccb9201f.tar.gz
gentoo-b5f4347bffcdb09bea028ac682f8e65eccb9201f.tar.bz2
gentoo-b5f4347bffcdb09bea028ac682f8e65eccb9201f.zip
dev-python/httpbin: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest1
-rw-r--r--dev-python/httpbin/httpbin-0.10.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index 47908390a50a..1b7e09265efb 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -1,2 +1,3 @@
DIST httpbin-0.10.0.tar.gz 103729 BLAKE2B 1daff5bd9eba62c224d4fd6030e3c3378f849365d0e94f04e890fe555537580841bb4bc6868d04c0b64599aa09bf697f331b091f6a4c0450f23bf047fd0da887 SHA512 4fae4fe22cb1870acd31f51c25c1bbe946cfe9be88a63f0ba8d7078d2c48089d794726e86290fc41fa38dcf72f8573f054286cb47ab7518e953b7aafa4518215
+DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
DIST httpbin-0.7.0.tar.gz 92613 BLAKE2B 59252df1d4d0ef853ec65263b472d3ba6c597336d844f9b457f2d0a009048d4222f715a7f6fb120aca00fa641d1687e302036dc151bd2fd67ba98cf5fc47a63a SHA512 82e80058b58943637e9f8191764cea79bf7a6e40f36069f9b5d3f908585dbef20a03ef070d1f865d350920b6e874a93a48a544b05c14ff4911038ec2c20f6f63
diff --git a/dev-python/httpbin/httpbin-0.10.1.ebuild b/dev-python/httpbin/httpbin-0.10.1.ebuild
new file mode 100644
index 000000000000..9a3e1438b72c
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="
+ https://github.com/psf/httpbin/
+ https://pypi.org/project/httpbin/
+"
+
+LICENSE="|| ( MIT ISC )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~riscv ~s390 ~sparc"
+
+RDEPEND="
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flasgger[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest